CompressFiles Activity filename issue - the first letters of files are deleted

Using UiPath.Acitivities.System.Compression.Workflow.CompressFiles,
the first letters of files are deleted!

[Example]

  1. “abc.txt”, “efg.txt” files are in the “folder1” folder.
  2. I compress the folder with the activity
  3. “folder1.zip” is created
  4. The filenames which in “folder1.zip” are “bc.txt”, “fg.txt”

What would be the reason?

1 Like

Hello @WJ_Y

I do have the exact same issue. I see there’s been no reply here so far, any chance you found the solution in between ?

Eventually this topic will be picked up ?

Florent.

@florent.mathey and @WJ_Y
I tried now it is working perfectly for

Hi @Sudharsan_AIT ,

Thanks for your reply. I believe your response has been truncated :slight_smile: .

I aim to zip all the files generated along by the process execution in the daily folder created automatically :

The Archive is itself created inside the daily Folder successfully

But when I look into the archive, all file names are missing their first character

Properties are pretty generic themselves

Any hint welcome !

At your disposal,
Florent

@florent.mathey I am not sure about it

Can you try to change the “Encodage du nom(Name Encoding)” to System Default and try once?

Thanks and Regards
Sudharsan

Hello @Sudharsan_AIT ,

I actually tried it initially with the system default setting. The first character is still truncated and in addition the french character “é” is broken as you can see the result below, an even less ideal situation :

Sorry, I could not find the solution.

I’ve switched to the Zip activity of the Balareva.External library :slight_smile:

1 Like

@loginerror @Pablito - Could you please Look into this??

Hi!
Thank you for reporting this issue. I pushed it forward to our devs.

Hey @prasath17 @florent.mathey,
Can you please help us replicate this issue? We want to provide a fix but we can not replicate the behaviour in dev environment.

Can you share a project (including workflows) where this issue replicates?

Also:

  • What OS are you using?
  • What language pack are you using?
  • What version of the system package are you using?
  • What Studio version are you using?
  • What folder path are you using as the target for compressing?

Hi,

I had the same problem but its working now. Dunno if there was any update from the time the problem was inicially reported and now. From what i can understand, you have to pass the full path that the file has.

ex: c:\desktop\test\test.xlsx

i wasnt doing that. i was doing something like this:

c:\desktop\test\test.xlsx|test1.xlsx and so on. instead of:

c:\desktop\test\test.xlsx|c:\desktop\test\test1.xlsx|c:\desktop\test\test2.xlsx and so on.

After i made the necessary adjustments, it started working.