Compile error message says" ')' is needed " : when I input ArrayRow in UiPath.Core.Activities.AddDataRow

Dear Community,

I have been self-learning UiPath (Community edition) for over 3months, and I am trying to create PDF data extraction process using following example tutorial on youtube.

and after I tried to add ‘ArrayRow(Object)’ in ‘UiPath.Core.Activities.AddDataRow’ propaties,

I found the error message says
‘argument ‘ArrayRow: while processing formula’(InvoiceNo,InvoiceDate)’ compile error occured. parenthes ‘)’ is needed.’

but after I end with ‘)’ in this line, it is still asking me to add ‘)’.

How can I solve this error? additional type change action or something is needed?

I attached UiPath Project I created.
PDF Invoices (854.7 KB)

  • I tried to post in Japanese section before I post this question, but the “Create New Topic button” was unable to click(grey out for some reason), so if my explanation is not clear, pls let me know.

thank you.

Hi @Mot_Mor

You have to enclose array row with curly braces {}


1 Like

Replace () with Curly braces {}

1 Like

Hi @pravin_calvin , thank you for your prompt answer! I confirmed it works, thankyou.


Thank you for your prompt answer, I confirmed it worked with curly brackets{}, thank you !

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.