Comparing Filtered and unfiltered Data in a Widget

Hi There All,

I am having difficulty getting the data I require in a widget in Insights.

What I’m trying to do:

Get a Percentage total of successful Queue Items containing certain words in the output data of the queue items, compared to the Total number of Queue Items.

However, whenever I apply the containing Filter it restricts all the other data so I can’t pull the total number of queue items without the filter being applied here also.

Is Pivot the incorrect widget type to use here?

Any information/help would be great.

Many Thanks

The formula in the values section needs to be edited. You are taking the count of the output field and dividing it by the same number, so you will always get 1. Select the output field in the numerator and filter that field specifically on the specific words you want to capture. Then, the denominator should reference the total number of queue items, so you can use the function count with the parameter of ID (for the queue item). Also, the data model can be found here

Thanks for the response!

I actually had edited the second value ^ but it still doesn’t change anything :confused:

Right, but the second value should be total transactions. You want the count(filtered field1)/ count (id (queueitems))

1 Like

Hey Thanks again. But, I need the filtered to be a percentage of total, so this way around. Please see below when I separate both functions, I get the same value, 3rd column is filtered:

Got it, so then it seems like your filter isn’t filtering correctly. Do you mind sharing the data for the items containing the specific text? Maybe there is a subtle difference that you need to adjust

A suggestion here from my own filter explorations - when you apply a filter at the widget level (like you have in the filter pane on the right in the screenshot), it will filter everything. The way to apply a formula-specific filter is the following format:

[field 1], [filtered field1]

you can see an example of this in the processes template. check out how we do success %. to filter the second part of the formula (aka the filtered field 1), first type field 1, field 1. then click the second field 1 and select the filter option. filter what you need to, and then it will apply this filter for that field.

let me know if that helps!

Hi There, thanks again, please see the filtration.

I seemed to have found the formula/solution:

It seems you need to include the filtered data AS WELL AS the original data, before the calculation takes place.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.