Community Edition error


#1

Hi
We run a licenced copy and also a comunity edition for development, the comunity edition is displaying errors when we are loading any of the processes (see attachment) I have tried reinstalling the packages

Does anyone know what the issue is.

Thanks
Dave


Certain packages not getting returned in the search
#2

Please install/update

  • UiPath.Framework.Activities
  • UiPath.Core.Activities

available in Activities Pane -> Manage Packages -> Local


#3

Hi Badita
I had already tried that the Core is version 2016.2.6131.32218 and the Framework is 1.0.5905.30080 but it still errors.

Dave


#4
  • what other activities do you have in that workflow?
  • are all the corresponding packages installed/updated?
  • when did you build it and what version have you been using for this?

#5

Hi
I have loaded a number of processes that are working on the licenced version but error when loaded into the community version. It was built in the full version.

Dave


#6

Hi

Please go to Manage Packages and update all your package and the Error will disappear.
Thanks,


#7

Hi

Sorry for the delay in replying, I abandoned the community version and just used the full version but I need to develop while the full version is running so I am back on the community version but still get the error.
I have installed every package available I have unticked the filtering and I cannot see anything else to install.
Also notices in the imports Uipath.library and Uipath activities is showing Namespace cannot be resolved
Thanks
Dave


#8

Hello Dave,

I had a problem once where everything was installed and had to uncheck the filter activities and search for credentials manager in order to solve this issue, according to your first image I see that the uipath core actvities are missing can you try to uninstall/install again?


#9

Hi Beesheep

I had completly unistalled the community edition and reinstalled and still the same, I have just unistalled the two packages and reinstalled but still the same.

Dave


#10

This error looks similar to this topic:

Please check with V7 compatibility pack.

If that doesn’t help, could you share the workflow in question? It looks like it’s trying to reference deprecated namespaces (UiPath.Library and UiPath.Activities). If Region and TypeInto are the only ones used, it should be possible to change it manually in the xaml by pointing it to new addresses, but if your other version is still V7 and compatibility pack doesn’t solve it, you might be out of luck on this one :frowning:

Alternatively, if you can’t share the workflow itself, could you share just the lines from beginning to this one:
</TextExpression.ReferencesForImplementation>
and at least one with a TypeInto activity.
It should be enough see what it’s trying to reference and thus what’s missing.

Regards,
Andrzej


#11

Hi Andrzej

Do you know where I find the compatibility pack ?

Dave


#12

Go to ManagePackages -> Available and type “V7” in the search box.

Screenshot below (it finds it for me from both All and Gallery, but Gallery generally works quicker when you uncheck “Filter Activities”, hence the screenshot is from there).


#13

Thanks Andrezej

That worked !!

Thanks again
Dave


#14

Hi Andrzej,

When I search for V7 under Packages > Available > All or Gallery, nothing shows up. :frowning:

Is there another way I can download this package?

Screenshot attached.