Community Edition Activation Question

Hi,

I have a question about activation. I have activated the community edition license but in order to start my bot sequence, I need to be connected to a VPN. When connected the VPN blocks UIPath from connecting to the internet. The problem I have is that every time I try and run my UI sequence it wants to try and validate my license and therefore I am unable to start my sequence when connected to this VPN.

I wanted to check if this was how UI path works for community edition or if there was a way around it?

I can just write the connection steps to the VPN into my sequence but it can be quite time consuming to have to run the sequence from the beginning in order to test a specific part.

Any help would be much appreciated.

Hi @Davesab

Normally in order to run the studio, we dont have to connect to VPN, have you installed uipath in office network.

To run sequences in Uipath you dont need the internet connection, it works locally

Can you run your sequence and provide the screenshots?

Hi,

I need to be connected to the VPN in order to run specific sequence. This is on a local intranet web page. However, my problem is whenever I am connected to the VPN and run the sequence I get an error message saying my license needs validating, even though I have validated it already!

Unfortunately, when I am connected to the VPN I am unable to validate that it is the community edition because the app is blocked via the VPN. I get an error message saying there is no internet connection.

I am assuming from your response that the license doesn’t need to be validated at the beginning of each sequence run and that you can run a sequence offline without an internet connection.

Hi @anil5

This is the problem…

I run this simple sequence to open a browser when I am disconnected to the VPN and it works. I then connect to the VPN where UIPath is blocked from connecting to the internet and I get an error message saying I need to activate the license.

The strange thing is the problem also occurs when I am not connected to the internet. I can switch off my wifi and then try to execute the sequence and I get the same error message. It seems like an internet connection is required every time you run the sequence in order to validate the license?

Does this mean you are unable to use this tool offline or is something else wrong?

Any help would be much appreciated.

Hi @Davesab,

Which version of uipath are you using?

Can you provide the installation and license steps you have followed while installing uipath studio.

Hi @anil5,

I am using version 2019.4.2

The installation steps were:

  1. Use the UIPathStudioSetup.exe to install the application.
  2. Once installed the application opened and I was requested to select a license type.
  3. Selected community edition.
  4. Had to provide an email address and the device ID was already populated.
  5. IE opened with a popup confirming my activation on a UIPath website
  6. Ready to start using UIPath.

Hi @Davesab,

Can you follow the steps mentioned in the below 3 posts and let us know if it works or not

Perform a full reinstallation by deleting the old folders of UIpath and install again

1 Like

Thank you @anil5.

I have tried updating the dependencies using the mass update tool as suggested and i have uninstalled the application, deleted user data and reinstalled unfortunately there is still a problem.

The application does work; however, if there is no internet connection available, UIPath is unable to verify the license before I run the process. I have tried installing UIPath on a different laptop and it seems consistent that you are unable to run community edition processes without being connected to the internet (even if you have activated your community edition with a connection).

Hello Davesab,
Did you get the solution for this. I am also getting the same problem with this same scenario.Can you please help me to solve this.
Thank you.

Hi @Nayana11,

The conclusion was that you require an internet connection before you are able to run your process in the community edition.

The only way I was able to get this to work was to include connecting to the VPN as part of my process. Therefore, when I started the process I had a valid internet connection and then after the connection to the VPN it was suspended. This allowed for the community edition license to be validated at the start.

The problem with this approach was that I had to wait for the VPN to connect before I could unit test any part of my process. This was a time consuming approach but the only workaround I was able to think of.

1 Like

Try reinstalling uipath while VPN is connected.

I think that it directly depends on the VPN provider that you are using. When you face some issues, the best way to check is to use another combination of VPN and uipath software. I am using VeePN and can recommend it. If you got the same issue with another provider then you can check settings of your computer.