Cloud Studio install 21.10.5 service mode unattended robot does not run

I have installed UiPath Cloud Studio version 21.10.5 with advanced settings in service mode on a Azure windows instance using a service account per the instructions in the link below:

We are using Cloud orchestrator. I see that the UiPath Robot service is correctly installed and running as the Local System account as it should.

When I configure and use a robot account on this instance (03) with a machine template key that works on another instance (02), the unattended robot job does not run. I specify the robot account, the machine, the hostname correctly in the process start page. I have the non-production license applied to the machine and the job correctly. It just sits in the Pending status and does not run in Cloud Orchestrator tenant.

The same test job runs on another second instance(02) with the Studio Cloud 21.10.5 with the unattended robot option. The second host has the same machine key of the same machine template.

Is this a bug? Or is the Studio with service mode not supposed to work?

I am aware that there is the alternate option to use unattended robot install option with advanced settings and choose to install studio. I have not tried this yet. Has anyone else? Is this option supposed to work better with the unattended and attended robots and studio for development?

I’d like to know before we go too far down this path or try the alternate install.

Our setup works separately with studio on 1 instance (01) and automation developer with the user mode and unattended robot on the second instance (02) with the unattended robot setup.

We’d like to see if the Studio development and the unattended robot can work on the one instance. This is what I am trying on a third instance (03) to see if we can use 1 instance for both development setup and unattended robot with a service account.

Thanks for all the help.

Hello @vchawla1!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

I opened a case for this issue. The support was great.
The issue was that 1 non prod license can be used only on 1 host not 2 hosts for the same machine template. If using 2 hosts and 1 license, then whichever host connects to the machine first and acquires the license works and other does not.

To avoid this, we can go under tenant → License → see more → disable the license on the host we are not running the unattended bot on and enable the license for the host we are running the unattended bot on. This worked.

2 robot accounts on the same host will work with 1 license. That is why I did not run into this on dev 02 with 2 robot accounts.

Per UiPath support separate studio and robot host and combined studio and unattended robot on 1 host work for development purpose. If combined, we may run into performance issue and need to keep an eye on memory.

Hope this helps someone.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.