Client Security Hash - click button error


I’m getting this error in Client Security Hash exercise:
Click ‘BUTTON’: Cannot find the UI element corresponding to this selector:

Can you help me with this?


Hi @kampro,

  1. Go to the click Button which is giving exception.


  1. open the menu and Click on Edit Selector


  1. Click on repair and reIndicate the elemnt to match it to the live selector


@kampro Can you show us the Selector?

Hi @mukeshkala,

The Repair option is inactive, what I see is:


The selector is:

1.Click on validate - if it’s still green , we are good with it .

  1. Open the webpage with the button on top , Click on highlight and see if it points to the correct button.

3.if not , use indicate element to repair the selector.


Is SIMULATE CLICK property enabled
Kindly check that once and try again

Cheers @kampro

Hi @mukeshkala
When I open the workflow I can see Validate button in red:

when I open the website and use repair and re-indicate the button is on green, but still the same issue. Maybe I should do it one more time, the whole process??

Hi @Palaniyappan,
Yes, the simulate click is enabled.

In the above selector -

  1. Please alter the following attribute in selector .

Title = ‘Acme System *’
Aaname =‘Update *’

  1. Still not able to get it
    Click on" Open in UiExplorer" from bottom left and add more attributes to the selector.


Hi @mukeshkala

Still the same…

Hi @kampro

You may try an “Anchor Base” element to catch the secure button.

In that, put “find element” in anchor (which would be any element near the secure button) and click in action activity by targetting such secure button.

I have resolved my bug by doing this.