Client Security Hash 0/100

Hello everyone,

I have uploaded Client Security Hash assignment as I have finished building it and it works well without error, all items are completed, and the hashes are correctly built.

Still it gives me 0/100, I have not the foggiest idea why.

Could I get some help ?


You must follow the walkthrough exactly as written. Even if your project runs successfully and correctly, if the project does not meet what is expected from the walkthrough (the step-by-step guide; not the process documentation), then you can still fail.

What’s the point of doing it, if after all it must come down to the very same sequence written in the walkthrough ?

I also tried with one I found on github, it does not work either

I agree, as I made the same mistake. However, as mundane as it might sound, the way to pass is to follow their instructions exactly as written.

One solution that exists in other websites, is to set a peer review assignment with one or more peers correcting it (and earning I dunno a badge or something?), it gives a community drive and would make way more sense than this poor auto correction.

Hi @raphael_rpa

Please go to ACME Systems>Account>Check Assignment Result and see if your transactions are completed successfully.

Hope this helps!

1 Like

Hi @Sheetal_Dayal , It says “Unauthorized”

Does this happen when you access the assignment result or any work item?
Try printing the transaction values when you run it and see if any value is incorrect. Or may be clear the cache and the least try reset your test data and run the process again.

You can also check this link:


Hi @raphael_rpa

Do check your hash code, try this :point_down:


Can any one help me
My bot run successfully and all the workitems are uploaded successfully
But when i test one WI5 id the uploaded hash code and the hash code which i have tested is not same what is the reason can anyone help me please