Click with "Simulate" is not supported for this element

Hello Folks,

While filling the oracle java form, I have user simulate click to work in background. But error occur like ‘Click with “Simulate” is not supported for this element. Please use other input method’.
I have install uipath studio on window server. I can’t use simple click because i need to schedule that form filling activity. So in background simple click won’t work. My bot stopped at when oracle form is open and click(simulate) that goes in error.

Also I have already used simple click and try to run bot in schedule task but it stopped at the oracle java form and error occurred like ‘UI element not found’ .

Send window message also not worked.

Please help or suggest something else rather than simulate click on oracle java form automation.

Thanks in advance. :blush:

1 Like

That seems to be some restrictions on that oracle application and it is most likely to be the case with internal applications.

If you are using the selectors correctly by making them dynamic then the only way is to use normal click after using element exists.

The normal click failed as the element was not in the screen currently, right?

in that case, you need ti use Element Exists for that button, to reach to that button, you can scroll down the page using Pgdown hotkey or any other navigation shortcut in that oracle application, this will bring the button in the screen and normal click will work

Hi

welcome to uipath forum @tulasi_kaneriya

First let’s try to upgrade the UIAutomation package version
Go to Design tab → Manage Packages → Project Dependencies-> upgrade UIAutomation activities package and give a try

Or

Did we try with SEND HOT KEY activity with enter as key

That would work either

And ensure that JAVA Extension is installed

Cheers @tulasi_kaneriya

Hello @tulasi_kaneriya

Welcome to Uipath Forum.

UI element not found error, could be an issue due to an incorrect selector. Please make sure the you’re using the right selector (incase its changing dynamically).

Pls Try and post the screenshot of error, if it still exist.

Thanks,
Jeshwanth

Hi @tulasi_kaneriya ,

Click with Simulate is supported by Java Elements that specifically implement a certain interface (AccessibleAction AccessibleAction (Java Platform SE 7 )). Probably, the element you are trying to click does not implement this one.
Can you share with us the default selector you get and a picture with the element?
Have you tried to do the action using the latest UiAutomation Activities package?
Can you upgrade to an UiAutomation version later than 21.2 and provide the className property after indicating the element using UiExplorer? (UiExplorer → Property Explorer panel?)

Activity : Click on Oracle Java form

as per the below image, I have to click on that element.
image

But when task is invoked i got below error,

Error {“message”:“Click ‘page tab’: Timeout reached.”,“level”:“Error”,“logType”:“Default”,“timeStamp”:“2021-10-11T15:52:54.9505172+05:30”,“fingerprint”:“07e67f22-0b03-4e6e-a889-7e37472c06ae”,“windowsIdentity”:"",“machineName”:"",“processName”:“Oracle_Login”,“processVersion”:“1.0.0”,“jobId”:“ee892ff5-8a37-4779-913b-80532a3d9aa3”,“robotName”:“tulasi_kaneriya@atul.co.in-attended”,“machineId”:1361735,“fileName”:“Main”}

Selector value is as below:

image

@tulasi_kaneriya ,

Then it’s simple. Use the SelectItem activity to select the correct tab, which is also an action that is done in the background. That specific element doesn’t support Click with Simulate.

@vlad.coteanu
How can I use select item activity on that? It’s not indicate that element on screen.

Yes, it should indicate a larger area, which is the whole PAGE_TAB_LIST element (that is the role). And, after that, the dropdown of Select Item should be populated with the correct page tab titles.