Click related activities are not working

Hi there,

Sometime ‘Click’ related activities are not working until i click any window-screen

Anyone knows this weird error and Solution??

below pic. is just an sample

first ‘Click image’ is work then after the Send Hotkey, Any Click activities are not working
unless i click window manually…

I don’t know why but i figure it out.
it is only happened when using ‘Debug’ or ‘Debug File’
those who have same issue try to run w/ just ‘Run’ or ‘Run File’

1 Like

What is the input method you are using?

@sangeethaneelavannan1 I tried everything :cry:

SendWindowMessages, SimulateType : Default, True, False (every combinations)

it is really weird… if i click mouse on the any screen
it is start to work again… but RPA is for automation right?

i can’t check it everytime :cry:

Hello @Peace_Maker ,

Why aren’t you using the Modern Design Experience (info: ) instead of classic activities?

You could take advantage and use Descriptors ( ) which are finding an UI element by using all three methods of targeting available: Selector, Fuzzy Selector, and Image.

Best regards,

It is under container or use attach browser might help?
It should work and never faced any such issue earlier

My workplace RPA doesn’t have Modern Design Experience Option can’t even try it

@Peace_Maker Any reason for click image? Why not click activity?

Some works are using Remote Desktop Connection so can’t get select attribute…

and also some Application that using here also can’t get select attribute…

if try to do normal Click, it point the whole screen :cry:

In that case,try with ocr click activity.

Sorry for late reply…

Seems like OCR click activity is not working too…
it is work but same issue w/ first one…
click related activities r not work until i click anywhere…


Did you update any packages recently or studio?

and change this wait-for-ready property

Nope didn’t update anything and i try that too

actually we can’t update the RPA (current ver. Pro 2020, 20.* Activities)
coz it may be have a trouble w/ some old Process


How the issue is solved?

I think there is some diff. btw ‘Debug’ and ‘Run’

if i use ‘Debug’ some events after click relate functions are not work…
but if i use ‘Run’ it is work

I don’t know the reason why it is work… :smiley:
but it means i can’t try debug w/ that work :cry:

@Peace_Maker Hmm interesting

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.