Click one by one on image without id

Hello there,

I’m trying since this morning to make the robot click on each image (last column) of the list. However, there is no id to hang on and the anchors don’t work.

When I try to change the anchor code to a dynamic variable, it doesn’t work, it always takes either the first image if I don’t touch anything or tells me that there are too many similar ones. Or if I change the code, it always clicks on the image of TORCY whereas the variable indicates well the anchor of the first line.

Does anyone have a solution ? (the others topics doesn’t help me :face_with_spiral_eyes: )

Thanks in advance !

Christopher

we would recommend to check if TableRow attribute is offered and can be used for the dynamization

a (dynamic)selector in general could look like following

<Parentselector/>
<selector to the table/>
<webctrl tag='ROW' idx={{idx}}
<webctrl tag='TD' maybe some more additionals or idx='9' />
<webctrl tag='IMG' />

when working with dynamic selectors then always set a default value representing your test case

Thanks for your answer.

I tried a lot of modifications to see, but nothing worked. I have a tableRow here, should I put a variable that increments? I had tried manually changing the value but it didn’t work…

This is my UI Explorer :

I need to add some reference ?

first we would recommend to retry also when it fails on the first shot
try to balance of being general but reliable when forming the selector
(kindly note we gave you the hint on also using more selectors lines)

we dont need aaname, there is only one image in the row (be general)
we do have tableRow and can dynamize it instead of rowName, remove rowName

just try this, set on the default value different row indexes and validate it.

In general we had implemented similar cases and it was running sucessfully

Kindly note: current Selector is fixed by you to row index 2 tableRow=‘2’ ← here we would recommend to dynamize

Do you want i do that ?

2022-06-22_16h45_42

For the anchor i do that (dataVedior = data in ID RHE column) :

I still have a little trouble with selectors without id, I don’t know if I did it right :confused:

wildcard the title (parent selector)
provide a defaultvalue e.g. 3 for variable
remove the fuzzy selector
validate it

Thanks for your answer

By parent selector, did you say title or parentid ?

2022-06-22_17h04_19

Hello.

Try to understand what is the logic of tableRow. For example, 2, 3, 4, 5… or 2,4,6,8…
Then just increment.

Hug