Click on Element Failed... not always

Hi,
I have a problem with a bot.
Work on Service Now.
After a series of checks in other environments, he must return to a grid, and fill in some cells.

For each cell, I have created a dynamic Selector.

For example, to write in the CoupaTimesheet cell, the bot has to click on this selector

‘html title=‘Approved Values by PO Lines [BOT view] | ServiceNow’ /><webctrl isleaf=‘1’ tableCol=‘8’ tag=‘TD’ tableRow=’"+TableRowStart.ToString+"’ /’

To click on the next ones, I increase the row number and the column number.

Most of the time it works.
But random, for no apparent reason, does not find the selector, and the bot goes into error.

What do you think could be the cause? and how can i solve?

Thanks…
Aaron

Hi @AaronMark
May be some delay issues like loading of page etc i think so …

I had already thought this might be the problem.
But that’s not it.
I have already set some delays in the stream.
The bot is already on the Service now page. On this page there is a grid, with several lines, like that of the image.
Sometimes few, sometimes more than 50 table rows.
The Bot starts writing the data line by line (the data is always the same repeated).
Generally everything is ok, but sometimes, for example the 10th line … (random number) does not find the selector, even if for all the previous lines, it has always worked well.

Maybe I could use a retry scope, but I’ve never used it.
I think I have to put it in every step.

image image

Can anyone help me understand how to use it?

Hi @AaronMark

You are getting the last row number dynamically or you specified it manually?

@AaronMark

Remove the click activity…and replace type into with below properties…
Pass that dynamic selector(‘html title=‘Approved Values by PO Lines [BOT view] | ServiceNow’ /><webctrl isleaf=‘1’ tableCol=‘8’ tag=‘TD’ tableRow=’"+TableRowStart.ToString+"’ /’) to type into activity and set the below properties of Type into…

  1. Click before Typing : True
  2. Simulate Type : True
  3. Wait for ready : Interactive

If it does not work then let me know

WoW. Interesting. I did not know this possibility.
I try.
Maybe I’ll have to keep monitored for some time.
As I repeat, the error on the selector is very sporadic.
Sometimes x days everything is ok, sometimes, like yesterday, twice in error.

But I don’t know if I will solve the problem.
Yesterday, the error said not to find the click selector.
That is, as if he had lost the information of Dynamic Selector.
With your command, do you think it can solve?
it may still fail if it doesn’t recognize the selector. (it’s my idea).

If it does not recognize the selector then it will fail in any way but there can be several other reasons to get it failed…
The suggestion will help to get rid of it…
And you don’t need to change the selector two times always for click and type into…There will be just one…

Hi Pravin…
I tried using your suggestion in my flow.

Problem 1: writing inside the SN cell requires a double click, or click + enter to activate the cell.
image
:thinking:

I wasn’t aware of double click…
add your click activity but keep the same properties I’ve highlighted in the screenshot …