Click OCR Text Issue

Greetings ,

So there is a generated table in web app - we have to use chrome.
And I have IDs I need to click (EX. AX222/F , AX222 etc.).
Tried many different things and settled with OCR click text activity.

My problem is, it only works if table returns multiple LINES/ROWS!!!
When it gets only 1 row (I set timeout 130sec) it waits and throws activity timeout error.
And with multiple rows it finds the ID within 10-15 sec and clicks it without a problem!

I tried changing engines, I tried using different Scaling(only worked with scaling : 3 ), tried all profiles and nothing works!
I also tried click text but that one fails instantly.

Hi @Aryx!
Can you upload your workflow for analyze your problem?

Appear to your case can be better use regex, more faster and probably more accurate :slight_smile:

Hi, can you elaborate ? How will I click text in table with regex?

Let me see if I’m understanding correctly, you need to click in the Id or you just need to get the string of id?

Click it, among other IDs

Hum…Will be more easy to help you if you can upload your workflow for see the case in detail

At this stage there isn’t a point to upload entire workflow, as only this activity is not working.
PS. it also highlights the area it needs to scrap during debug. I can post the configuration screenshots.


2019-12-13_15h07_12