Click generic error in origin

Hey, I’m new to Uipath and I’m trying to use it for spectrum analysis in origin. So when I try to click on the open file in origin’s dropdown menu the “click generic error” occurs.
I have tried using recording, attach window and directly using the “click” activity but none of them works.
Does someone know how to fix this?

Depending on how the application was developed, you may have to use different click techniques.

Please try clicking the element with the “SimulateClick” or “SendWindowsMessage” properties set to True. If it’s a particularly difficult button, you may also be able to use the “Set Focus” activity and send the Enter key using “Send Hotkey”.

hmmm, where is the simulateclick? I’m sorry I can’t find it…

No worries!

It’s right down here in the properties panel (right-hand side of the screen):

2020-02-12 23_09_39-UiPath Studio - BlankProcess1

So that still gives the click generic error.
This is how the sequence looks like…

@FrankChen Do you have a Shortcut Key for the Open Option? If So, Try Using Send Hot Key and pass Shortcut keys to it

@FrankChen As @supermanPunch mentioned you can use Send Hot Key, I can’t see clearly because screenshot is small but looks like alt+f+o will do what you need. You can type in the letters that corresponds to the hotkeys you want to use. e.g in the image below


It worked! thanks so much!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.