Click acts differently human vs robot

I have a problem clicking a button in the client’s ERP system.
When a human clicks the button after opening the dropdown menu, it sends an email with an attachment, like we want.
When the robot clicks the same button, it sends the email but without the attachment. And I cannot figure out why since I have tried a lot of different things, for example hotkey (enter), simulate, window message and physical clicks.

Any tips what to try next or similar experiences?

Hi @sinikka,

If you select the item with Select Item activity, sometimes it selects like simulate and system cannot understand it. Kindly select without Select item activity, if the problem continues please respond.

Kind Regards.

Hey! Thanks for the reply.
I’m not using Select Item activity, instead I’m using Click activity. Since Click doesn’t work, I figured the Select Item won’t help me get forward because I have noticed it isn’t very reliable. Might even be it doesn’t work, I didn’t do the first version of the project, so I haven’t tried.

Hi,

Can you post the screenshot please, maybe it should be more helpful.

Kind Regards

What kind of screenshot would help? I can’t post anything too revealing.

Could you kindly send the dropdown menu and which button you need to click, if it is not confidential of course.

Here’s a screenshot of the dropdown menu and the two buttons I’m trying to click in separate sequences. They both send an email with an attachment but when the robot clicks, the attachment is not sent with either, only the email.

1

Here’s the plus button (Muut) and it’s dropdown buttons in the UI Explorer.

2

Sometimes, I cannot figure out the reason, the dropdown buttons are empty so here’s the screenshot of that as well.

2

Click may be having trouble for triggering the system, here I suggest you scroll down with the send hotkey and then send enter hotkey.

Yep, I have tried down arrow buttons and then send enter hotkey. Sends the email without the attachment unfortunately. :confused:

Actually im out of ideas. I could say that the click selector doesn’t work, but if it doesn’t work with the send hotkey, I don’t know how we can do it.

Hello @sinikka

Can you try executing it in debug stepinto method and see whether it’s working as expected? If manually email is sent with attachment, it should work with automation also.

Enable highlight element and run in debug mode and see.

Thanks

Yeah I have tried debugging and running via Orchestrator with and without delays in between. It clicks the dropdown menu open from the plus button and then clicks the wanted button and then there’s confirmation window and the robot clicks OK. Then there’s the email without the attachment.

This is something strange. Can you open the application using and do the selections via automation and pause the execution using a break point. Then try to do the remaining part manually and see whether it is sending email with atatchment.

Thanks