Click activity waits a long time before it is executed

Scenario:

I am automating a process in IE and working with a web application. Certain times the click activity takes a long time to execute (it feels like it waits for the activity to timeout and then performs the activity) and sometimes it works like a charm. There is no exceptions thrown it just waits a long time before the click is performed.

I am not sure if it is the application or studio that is having this issue. But I have not experienced this behaviour before the 2018.4.1 update.

I am using the click activity inside a “on element appear” and I have tried ti set the “wait for ready” property to “none”. This helped a little but it is still slow on certain occasions.

The selector is working fine, as in the end (after the wait) the button is clicked and no error is thrown.

Steps to reproduce:

Create a process that works in a web application and click on certain buttons.

Current Behavior:

Sometimes the button clicks as it should but sometimes the wait time is long. It feels like the activity times out and then performs the action.

Expected Behavior:

The click activity is performed when the button etc. is available/visible without waiting 30 seconds

Studio/Robot/Orchestrator Version: 2018.4.1 Studio

OS Version: Windows 7

Hi nbjerke,

This situation may happen when UiPath waits for loading the entire page/structure. You can try changing value of Target -> WaitForReady from Complete to Interactive/None

Following is the significance of values of WaitForReady:
None: does not wait for the target to be ready.
Interactive: waits until only a part of the app is loaded.
Complete: waits for the entire app to be loaded.

Regards,
Tuhin

2 Likes

Hi @Tuhin_Samanta,

Thanks for the quick response. As I mentioned in my post, I have tried to set the property to “none”. It helped a little bit, but the issue is not completely resolved.

Yes.
I experienced same with 2018.4.1

sometimes using the click image instead of the click activity makes it work better/faster.

Hi
Can u tell us is that checked marked for WaitVisible & WaitActive

Also try this , go to misc=> Target.TimeoutMS => put 1000 (1 sec) and run and check whether it’s working within 1 sec

2 Likes

Thank you very much! Worked like a charm!!!