Click Activity Sometimes does not click a button properly in RDP

I have this button that I need to click, that would open/pop-up a page. The process is being run on the RDP which would be restore down while the process is running. The Problem is that sometimes, it won’t click the button properly. The selectors is correct and there is no error that came from the click activity. I’ve tried setting wait for ready to complete and turn on Simulate Click, but Simulate click won’t work on mine when the RDP is minimized or restored down. I have changed to setting from Simulate Click to SendWindowMessages, but this problem came.

I’m also using edge as the browser and I’ve already added the site to allow pop-ups. I have a retry scope for this which will retry for 2 times, with 30 secs interval in between.

Hi @RGT ,

Is there a Reason you are minimizing the RDP ?

We normally would have to Sign Out from the RDP Session for the Robot to work Properly.

Could you maybe try Signing out from RDP and Check ? (Assuming it is an Unattended Bot)

It’s running in Attended Robot so the RDP is minimized, but it tends to have some problems so we decided to restore down it instead.

@RGT ,
If that is the case, Maybe you would require to make some registry changes as mentioned in the following Documentation :

one workaround is open another RDP (rdp2), then from rdp2, remote to RDP that has the robot and run the robot from there

now you can minimize rdp2 from your desktop (but DONT minimize robot rdp from rdp2)

you can also look at this thread

This usually works on mine when Opening the RDP from TeamViewer. Problem is, I don’t know if our User would provide another RDP for this one. Is there other workaroud here?

We’ve tried this before, but apparently it still does not work. That’s the reason why we are testing it in restore down instead of minimize.

What’s weird is sometimes this works properly. There is like 200 scenarios that it would click this specific button. Sometimes, it would click the button properly from around the 1st to 100th transaction, then it would error from 101-115 then it would continue working for the last transactions. So I can say that it works 80-90%.

is your license attended or unattended?

We’re using attended