Click activity sometime can work but sometime cannot

When i use click activity in drop down activity like this 10 , sometime it give me the error like cannot find the selector.

but if i try to edit selector and indicate again the element, it run. but when second time i want to run the program again, it cannot run. I need to indicate element everytime before i run the program. Please give the the solution to solve this probelm. Thanks.

Hey @jiejie, why you want to click?

Use the Select Item activity to select your option.

Try this and let me know, if it’s not working!

Or if you want to click? Post the full Selector of your clicking option. I’ll tell the method.

Michael Udhaya

Hi, @Michael_Udhaya When i try to use Select Item activity, it show me this


Here is my full selector clicking option, thanks.


Fine, use only the table column and table row selector with title attribute.

Make sure your title is stable!

@Michael_Udhaya i follow as what you said just now. But i show me error again.


Okay let try another way to select the ‘Close’ option.

Use the Click activity to click the ‘Drop down’ and use the Type into activity, type “Closed”.

try this.

1 Like

@Michael_Udhaya cannot use type into in here

@jiejie I know select item doesn’t support type into. What i’m said is, try to do like a human.

first of all check the steps by manual.

  1. Click that Drop down button
  2. without clicking anything, You just type ‘Closed’ and see how it behave.

if it work, try in the code.

1 Like

@Michael_Udhaya I tried and i only can click the drop down button.

Okay if the type was not working! lets try this.

It is not efficient method. But it works.
After clicking the drop down button, use the ‘Down’ arrow for 6 times to select ‘Closed’ and then use ‘Enter’ key with Send hotkey activity.

put the Down arrow sequence in While loop for 6 times.


@Michael_Udhaya Thanks, it’s work !!!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.