Click activiti not selecting required field during automation run

Hi guys,

Facing issues in a click activiti. Need to click a radio button with a “No” label and i have anchored it to the question and label. I have made the proper configurations and used Strict selectors and image as targeting methods. When verifying it via Highlighting the UI element is properly targeting the desired output however when running the automation workflow the radio button associated to the “No” label is not being selected and another radio button associated to the question is being selected instead. This selection causes the workflow to break and fail the execution of the workflow.

I would really appreciate solutions to this kind of problem asap.

Thanks

1 Like

Hi @ajain1

Open the selectors of click activity and you have the attributes in the selected items in the right side of Ui explorer. Find the proper one and check that attribute which has no value for the target selectors.

Then try to do
For the Target check the strict selectors and uncheck the fuzzy selector.

If it is also not working better to give the multiple anchors.

Hope it helps!!

@mkankatala

image
here in property panel i am having value as no but when I am adding this in my selectors it is not getting validate

image

Uncheck the idx attribute and validate but Sometimes its not validate properly, it shows red color in validate button but it works fine.

If it’s not works

After indicating the element, come back to studio the open the target option in properties in that open strict selectors and select the option and validate.

Hope it works!!

1 Like

Can you provide a screenshot of your selector alongside the interface you are using?

1 Like

The idx is the problem. If the page elements change, the idx of the objects changes. You should never use idx in a selector. It looks like you have multiple ‘No’ radio buttons on the page. You need to make the selector unique to just the one you want to select.

Hi @ajain1

Remove the idx=‘20’ from the selectors and try validating and it must work fine.

Hope it helps!!

1 Like

You can’t just remove idx. That attribute indicates that there are multiple UI elements that match the other attributes in the selector. If you just remove idx it won’t know which of the UI elements to click. You have to add other attributes to the selector to make it unique.

1 Like

Thanks for help everyone!

1 Like

Thank you @ajain1

Happy Automation!!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.