CLI for interacting with UiPath services

Command Line Interface (CLI) for interacting with UiPath Services

uipathcli provides a unified command line interface for accessing UiPath resources. You can use the CLI to execute commands from a terminal, either interactively or automated through scripts.

The CLI makes it easy to get started using UiPath Service APIs and allows you to set up resources and automate small tasks.

uipathcli works on all major platforms (Windows, Linux, MacOS) and architectures (x86/x64 and ARM).

Getting Started

Follow the instructions to download the CLI on your machine. The CLI does not require any installation or additional dependencies.

Built-in Authentication

uipathcli supports interactive logins with hands-off credentials management. Authenticate using the browser with the OAuth provider of your choice in order to get started quickly. Client credentials and access tokens are also supported, in case you want to use the uipathcli from a script in an automated way.

uipathcli provides an interactive wizard which helps you configuring the CLI for the first time and it guides you through all supported options:

uipath config

API Discoverability

The CLI contains documentation for supported services, resources and operations through built-in manuals:

uipath --help

Enable autocomplete in your shell to increase productivity and learn about supported operations and parameters.


Try it out, enjoy, and let us know what you think. Remember, uipathcli is still in preview phase, a special time when your feedback, thoughts, or questions are more than appreciated, so please submit them here.



I would like to add assets in UiPath orchestrator through the pipeline, is there any way we can do that by using cmd command or powershell scripts .

Thanks in advance.

1 Like

Yes, you can run the uipathcli from CMD as well as PowerShell. In order to create a new asset, you have to retrieve the id of the orchestrator folder. After that you can create an asset within that folder.

PowerShell Example:

The following script retrieves the id from the Shared orchestrator folder and creates a string asset with the name my-asset in it.

$folderId = uipath.exe orchestrator folders get --query "value[?DisplayName == 'Shared'].Id" --output text
uipath.exe orchestrator assets post --folder-id $folderId --name "my-asset" --value-scope "Global" --value-type "Text" --value "my-value"

I hope this answers your question.

Hi @thschmitt,

This looks promising and very detailed. The cross platform CLI is great to bridge the scripting world, many admins will love this.

would like to use this using the PAT however, creating a PAT looks challenging. The PAT URL in the documentation is broken.

Once I get my PAT sorted out, I can send issues/PR in the github repository.

1 Like

No this is not working

It is showing the above error.

1 Like

I have tried to use an another method, deploying assets through uipcli, ended up with the following error.

1 Like

It looks like you are not using the new uipath.exe CLI for interacting with UiPath services. Please follow the instructions here to download and get started with the new uipathcli.

Thanks the issue has been resolved.
The problem was due to assets_file.csv file.

1 Like

Thank you for bringing this to my attention. I have updated the documentation to describe the supported auth flows in more detail.

Currently, the uipathcli supports two main auth flows:

  • Use OAuth 2 flow to login through your browser. This is the preferred flow when you are using the CLI interactively.

  • Use client credentials in case you want to use the CLI from a script in an automated way.

More details:

1 Like


This might sound odd, but I have set up the confidential application with Application Scope >> Orchestrator APIs >> Select All ( i didn’t want to, but things are not working as I thought they would)

If I try to query something I keep getting this error below. Where am I going wrong? I have tried it two different ways, but I get the same result.


cc: @thschmitt

The issue I’m having isn’t resolved. Nevertheless in yet another attempt, I tried the command in the github documenation, but I do not see anything that resembles UiPath du metering ping ?


I got it to work. I narrowed the scope down to just OR.Users.* and I was able to get it to work. I’m using CE and not really sure why Select ALL does not work or if there is something that I have to read somewhere.

As for the du metering, option I suppose it isn’t available for CE?


Hi There
I try to follow the GH link steps that you provided, and i download linux version in linux EC2 and i can see that this UiPath is in /usr/local/bin and executable, but when i run it it give me error:

any idea why?

I just realize that my previous question was quite stupid, because II did not realize that there are 2 completely different “UiPath CLI” released:

Maybe this helps someone else as well :wink:
(I came here through the forum’s search.)