Citrix extension is not working with UiPath.UiAutomation.Activites v19.11.1 or higher

Hi all

I have a process that is using an app inside a Citrix environment. This process uses a library that has an acitivity to login to the app.
Both process and library are using dependency UiPath.UIAutomation.Activities v19.10.1

When I update this dependency in the process and the library to v19.11.0 (or higher, tested until v20.4.1) the login acitivity is no longer working as the selector is not recognized anymore.
Without the Citrix extension I would see the same behaviour, so my guess is that v19.11.0 of this dependency is not compliant with the Citrix extension.

Studio version that I’m using:
Studio 2019.10.4 - 2/6/2020
Enterprise License
Windows Installer
License Provider: Orchestrator
Activation ID:
Microsoft Windows 10 Enterprise 64-bit
.NET Framework Version 4.7.2 or later

Is this already a known issue? Anyone else having the same issue?

Hi @Bjorn_Berghmans,
Welcome to the Community!
Between those two versions of UiAutomation package some huge changes were made. That means your selector might be not valid and need to be created from scratch using newer package version.
More details here:

Hi Pablito

Thanks for your suggestion, but it doesn’t fix my problem unfortunately.
With the Citrix plugin I was able to identify the fields/elements in my Citrix environment and get reliable selectors. But when I update the mentioned packages to v19.11.0 or higher, the functionality of the Citrix plugin is lost. When I try to update my selectors, it is only possible to select the whole screen and the a specific field/element.

That’s why I guess that the Citrix plugin is not compliant with v19.11.0 or higher…

Sorry for the typo: I can only select the whole screen and not a specific field/element.

Can you tell me if by Citrix plugin you mean Citrix Receiver/Workspace or Citrix WebInterface/StoreFront page loaded inside web browser where you are selecting application to run through plugin?
If it’s about the web page then I think there is not compatibility problem rather you have too old UiPath Extension installed in browser and this needs to be updated.


I mean the plugin that you can install via Studio.

In my process I first browse to Citrix WebInterface to select the correct application (this selection is still working fine).
Then I need to login into the application and from that point my selectors are not working anymore. I had the same issue in the past (before installing this plugin), that’s why I think in that direction.

I already tried to install the plugin again, but it made not difference.

Probably the reason why reinstallation is not working is because you are trying to install extenstion from same (old) Studio version. Try to download newest Studio version from platform.uipath.com and install extension from newer version of Studio.

I also tried that, but the issue is still not solved.

Studio 2020.4.1 - 5/8/2020
Enterprise License

Thanks for thinking with me though.

1 Like

Last thing about which I would like to ask you. Have you updated the UiPath Remote Runtime plugin on Citrix Servers?


You should update the UiPathRemoteRuntime from the Citrix server to match the UiAutomation version.

Hi Pablito

No, I didn’t update the plugin on the Citrix servers. That will probably fix this issue.
I am going to check this asap, but I need to depend on an external party to do this.

I will update this topic as soon the update has been done.

thanks again for your advice.

1 Like

Hi,

I have the same problem then @Bjorn_Berghmans. But I don’t think that to update the UiPathRemoteRuntime from the Citrix server will solve my problem.

For my existing project, if I update the package UiAutomation.Activities from v18.4.5 to 19.11.1, I am no longer able to select an object in my app. I can select only the whole screen. But if I create a new project for the same app (with the default UiAutomation.Activities v19.11.1 ) , I am able to select an object in the interface.

It is why I don’t thing the problem is about the UiPathRemoteRuntime from the Citrix server because it is already worked.

Someone can help me ?

Hi,
were you able to fix this issue by any means. I am also facing the same issue. Please let me know the work around if you could resolve it.

Hi Midhuna, IBU

Sorry for the late response, but we struggled with our upgrade to Orchestrator together with Citrix RemoteRuntime to version 20.4.

But since all applications (Orchestrator, robots and Citrix Remote Runtime) are on v2020.4.x everything is working again.

So in my case, updating remoteRuntime to the same version as the robot/studio environment resolved the issue.

1 Like

This what you wrote is exactly the case related to update Remote Runtime. The Runtime needs to be compatible with activities package version. If you were able just to mark whole screen that means your remote runtime version is incompatible with package version :slight_smile:

Thank you for the reply.

@Pablito/@Bjorn_Berghmans,

We tried keeping all the versions to 2020.4, but still I cannot get the selectors from Citrix application. Is there any reinstallation of plugins required to fix this issue.

Yes. From time to time if you are using newer packages those require newer runtime as well. It’s because the structure and code of activities are drastically changed and older runtime can’t interpret they “command” properly.

@Pablito, Thank you for your prompt response. Will try to work on it and come back if more help is required.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.