Citrix Automation - Enterprise application - Unable to click an Image

Hello Team,

We use Uipath in my workplace. But unfortunately we are facing issues w.r.t to citrix automation. I am trying to click a folder name in citrix app to expand but none of the usual (Click Image, Click OCR text, Keyboard shortcuts) seems to work. They don’t work always, Some times,they result in making some random clicks/doesn’t find the image. We cannot afford to go live with this kind of approach. Does anyone know any other reliable approach to select/click a folder. Once this is click is over, I need to follow it with several other clicks and keyboard shortcuts. Can’t paste code/screenshot as it is confidential

Kindly do help me/advise if there is any other method

Have you tried the following:

  1. send hotkey: wind + r (to open cmd)
  2. type into: the file path location of the folder

Check selectors.
This can make some problems…

Thanks for the response. I have to select folders within an window based citrix app. Under the citrix application, we have a tree like structure where we have to click/select.

Can you try to use relative click? Maybe it works.

I think that working in citrix is so tricky … had you tried using recording tool ?

what other activities you have before? sometimes is a delay problems when you tried to do something and is not working …

other option is try first to find the image and highlight this one before do click so you will be sure at least that is doing ok and is other the problem …

@Carmen Thanks for the response. That’s what I tried yesterday and its working as of now. I hope it works without any issues continuously. @madalinadicu But the issue with Click image and relative scraping is, they are not reliable.

Can you guys also have a look at the below post and help me with it?