CITRIX Automation CAPS LETTER ISSUE

activities

#1

Hi,

I am working on citrix automation project. I used Remote desktop and navigated to the VM login page and used Type into activity to enter user name and password. But strangely CAPS lock in not working which results in wrong credentials. Example: For ‘Uipath’ it is keying in ‘uipath’.
I tried - passing password variable, Delay Between keys but could not find a solution. Can anyone help me out to sort out this issue.


#2

hello,

can u plz share xaml or code


#3

@raj Use Get Password activity and store the password in a variable. In the type into activity, use the variable to assign the password value.


#4

Sorry for the delayed response, I was in a long leave.

Madhavi,
Tried with Get password activity and even converting the string to password and passed the value to type into still not working.

Root cause is due to VM network slowness.


#5

@raj If the issue is due to network slowness, add delay and try. That might work.


#6

I tried using delay and delay between keys in type into. Correct password is not keying in consistently.