CICD Azure Gives Error During Integration

How to resolve the error obtained In Azure Devops CI/CD, while configuring the deployment release pipeline the issue - " D:\TfsAgent01\_work\_tasks\UiPathDeploy_72167370-9f1d-47d5-be00-6f2554c20001\2.0.965899\cli\uipcli.exe; failed with exit code 1 " ?

Issue Description: While running and deploying the package to Orchestrator from Azure devops, an Error "Make sure that PackageName is not already deployed on one of the Robots from this environment" is obtained. This means the package being tried to deploy, is already available in any one of the Robot in the mentioned environment.

While trying to create a new environment with one Robot, the same error is obtained. On logging to that Robot and verifying the Robot tray, the same process is already available.


  • While deploying, if a Robot is shared with different environments ensure that the process is not already available in any of the Robot or try to limit the Robot sharing between the environment to avoid confusion
  • If the same issue persists, try to delete the process and package from the Orchestrator and deploy it again from the Azure devops.