Chrome issue : ask where to save is not working

I have a process of downloading a file from website and store it in the network drive, I prefer to download it in local and move it to network drive at the end process. Each time when i download, i had set up google chrome to ask me where to download. So that, i can change the file name and store it in my own customized path. i used set textvalue to give in Save as. and click the save button by simulate click.

It works 100% in my local machine. But, when comes to deployed in VM… the same process is followed, but when given the customized path, it is not saving there. it is defaulting to download somewhere else. I thought it would be a chrome issue though, but then - i changed my code to “Type into” activity instead of “Set text value” (which almost took 10-15 secs extra per record). it works fine.

Any idea on whats happening? any alternate solution out of box? suggestions are welcome.

Hello @Pradeep.Robot!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

Hi @Pradeep.Robot

Instead of changing the chrome settings,you can try moving the file from default downloads folder to ur desired path using move file activity once it gets downloaded.

Yes, thats right… but the Issue is - the site always saves in the defined name. Whenever it is clicked download to default folder, it saves with the name say eg. “xyz.xls”, the second file will be saved as “xyz(1).xls”, and third going on… In my process, i have to save the file with the customized name. it happens only when i save in customized folder using “Save as” and customized name.

U can do it using move file/copy file activity.

Source path would be .for eg

C:\Downloads\xyz.xls

Destination path

C:\Desktop\Report.xls (customized name)

If you use copy file activity, make sure to delete the file in default downloads folder once the action gets completed(using delete activity). So that ,it will be always saved as xyz.xls when u try to save/run the process multiple times.

I understand that, we can customize the each file and move it to the destination one by one. but, it is not so good to move the file one by one after downloading to another network drive (i mean not the best design). As, we have almost 3k downloads per run.

Instead, i can able to achieve the results by using the Type Into activity by typing the file name and click download. i want to gather the solution is why the set value is not working when it is working perfectly fine in local machine and not in VM?

Hi @Pradeep.Robot

  1. Have you tried entering the entire path along with file name in the popup. This will save the file in that location.
    Ex: D://Folder1/File1.txt
  2. In chrome did you change the default location from downloads to you desired location.

Hope this helps.

@sunilch - Yes, but downloading with default name is not working as i have to download more files in the specified time. Also, i have decided to save the total files in local and move all files in bunch to the network drive at the end of process (as there are intermittent issues in connecting the network drive, so don want to lose the file in saving after every download). So, i enabled the “Ask where to save” in your screenshot, which is the exact thing i mentioned here. when enabled “ask where to save” it works so perfectly in local. but in VM, the same chrome version… even though it pops up asking for the save location, it saves in default downloads folder with the default name only :slight_smile: it works perfectly fine if i use “Type into” and write the whole custom path in the “Save as” field and save it.