Chrome extension not detected everytme automation started


I have a problem whenever I want to start automation that has google chrome automation
The problem is whenever the automation started to running, it opens a new chrome browser, but without uipath extension

I have already installed the uipath extension and it is existed every time I check on the extension menu, but when I check on the chrome window that is opened by the robot, the extension disappear

Any help is appreciated, thanks in advance!

Hello @muhammad.raharjo

Welcome to the UiPath Community.

Are you opening the chrome in incognito mode?

No, i already run the “open browser” activity without incognito mode, and I have already tried every combination of the options under the properties tab


Have you tried updating or re-installing chrome?


Try this-

Close the Browser
In UiPath, Click on Tools option

Click on Chrome
Then click OK

Hi @muhammad.raharjo,

We have met this same issue, the approach below solved it for us, but the root cause for this issue is still unknown.

I suggest you follow this order

  1. Uninstall the extension which you have currently.

  2. Go to this link and install the extension again
    UiPath Web Automation - Chrome Web Store

  3. Close Chrome

  4. Open Studio navigate to Tools and install Chrome (That is right! Install the extension the second time but via Studio)

  5. Open Chrome again and click on the extension (if it is not visible you can make it visible in Chrome by clicking the extension icon first)

  6. Choose to administor the UiPath Chrome extension

  7. Give the extension the required access (On all websites)
    Check the required permission in Incognito mode. I dont have access to English version of Chrome now but the extension has the same options in all languages.

We also noticed that UiPath version 20.06 has some issues installing this extension (Step 4), so I also suggest if possible to upgrade to newer versions of UiPath Studio / Studio Pro

Hi Jeevith

Thank you for the quick & simple guide
I have one question; how can we install the extension if we don’t have the studio instance? Just use the command prompt?

Thank you

Best Regards,

yes already tried that, but still no success

the problem is the computer where the problem exist doesnt have studio installed, just attended robot, is there any workaround? (already tried installing with command prompt)

I cannot remember the entire details, but I think a UiPath Robot install does have a folder containing the chrome extension setup file.

You could use command line to install the extension after installing it throught Chrome Extension Store.

I cannot check this as we have studio installed (floating license) on production machines for quick troubleshooting.

Hi Muhammad,

Please check for policies which are applied to the user you logged in.

I faced the same issue and got it fixed by updating the policies.

When the policy is updated it will open chrome from different location itself.

Try clearing user profile and create a new one. there is possiblilty where issue might get fixed.