Chrome extension is NOT working with Chrome 64 bit v63 and v64

I’ve gone thru many cycles of installing / uninstalling the Chrome extension, but it simply won’t work.
I’m running on Windows 7 64 bits, on two different computers, one with Chrome 64-bit version 63 and the other 64.
Running with the latest extension in the store (9.0.6421). Not sure it’s significant, but the extension toolbar icon is gray, not blue.

I have the extension configured with both checkbox options checked.
The extension’s trace window shows the following in the console:
OnPageLoad not available; retry in later (this is in Loader.js:41)

When I try to select a screen element for the GetFullText action, I get different behaviors on the two machines (but neither one works correctly).

On one machine (Chrome 63), the whole page gets selected, but the child elements are not. When I click on the desired element (an H3), the Chrome Dev tools console shows the following:

Error in event handler for runtime.onMessage: ReferenceError: GetPageRenderOffsets is not defined
Error in event handler for runtime.onMessage: ReferenceError: N_TRUE is not defined

And the extension’s trace shows:

Unchecked runtime.lastError while running tabs.executeScript: The extensions gallery cannot be scripted.
at onGetHtmlAttribute (eval at (chrome-extension://dpncpimghfponcpjkgihfikppbbhchil/Loader.js:161:9), :1569:15)
at chrome-extension://dpncpimghfponcpjkgihfikppbbhchil/Loader.js:96:6
2VM39:343 ExecuteWithRetry: timed out while waiting to execute ‘onGetWindowIdForTabId’

On the other machine (Chrome 64) I’ve gotten various behaviors. Sometimes only the full page gets selected, or sometimes the right field is selected, but when I click on it, UiPath pauses for a long time, then displays the dreaded COM error.
extension trace shows:

Unchecked runtime.lastError while running tabs.executeScript: Cannot access a chrome:// URL
at Object.eval [as callback] (eval at (), :1724:19)

Both IE and Firefox are working fine for me, so this is unique to Chrome.

You should install the Chrome extension from UiStudio / Setup / Setup Extensions / Chrome

Of course this is what I did. How else would I have gotten the extension??

@stevefuzzy most of the time this is related to Dot.Net version in your machine.
Please make sure you have latest version (4.5 or above) of Dot.Net and you will not face any issues with extension.

@stevefuzzy sorry for the misunderstanding
did you have a chance to check the steps in Chrome Extension Troubleshooting Guide?

Is ChromeNativeMessaging.exe running once you open Chrome browser?
What is the version of UiPath that you are using?


Thanks, yes I tried all the steps in chrome extension troubleshooting. Basically the suggestion is to turn tracing, which is what I did, and included in my original post. However, that tracing info did not help me in determining the root cause.
I have the latest .net version

Hi Adrian,
Yes ChromeNativeMessaging.exe is running
using UIPath v 2018.1.2
The troubleshooting steps have not addressed the issue. And the last resort is turning on tracing, which is what I’ve done, and included in my original post.


Hi Steve,
I could only reproduce the error logs you posted on the chrome extensions page, but not on a webpage e.g. . It could be a permission blocking for the website you are trying to automate. Can it generate selectors for

Hi, do you have solution for this issue? I have the same issue with you. It confused me very much !:tired_face::neutral_face:
Thanks ~

The UiPath Chrome Extension wasn’t working for me either.
I tried uninstalling and reinstalling.
I tried restarting my computer.
None of those worked.
Then I looked at the code for the extension and found that the extension won’t reset with multiple windows open.
Each time I restarted my computer, my Chrome windows and tabs automatically reloaded.
Apparently, that prevented the UiPath Chrome Extension from properly resetting.
So this is how I fixed it and got the extension to work:

  1. I enabled “Allow in incognito”
  2. I enabled “Allow access to file URLs”
  3. I manually closed all Chrome windows and tabs, which allowed the UiPath Extension to reset and work properly.

If you want to keep all your Chrome windows and tabs, save their links first.
I use an extension called Tabs Outliner to do that.
If the UiPath Extension stops working again, you’ll need to manually close all Chrome windows again to allow the extension to reset.

If you don’t like to constantly close Chrome to reset the extension, you can try using a different browser for your automation, like Internet Explorer or Firefox.

I’ve got the same problem… tried all of the ideas above, but still can’t get the robot to recognise a mouse click on an element in Chrome.
The whole Chrome thing seems a little unstable. Stuff I’ve got working in minutes on IE simply doesn’t work in Chrome. Unfortunately I have to use Chrome for other reasons/dependencies.
I’ve seen lots of problems reported on the chrome store and here.

Before I give up on this software completely, does anyonme have any other ideas how to make this work… or whether UiPath are taking any of these problems seriously?

I was facing the same problem. I tried all solutions but no luck.

Today, I updated the Chrome browser version. It’s now Version 70.0.3538.102 (Official Build) (64-bit). After updating Chrome version, the issue is resolved.

1 Like

I guess the problem is with the chrome version. I faced the same issue and i overcome this issue by installing version 71.0.3578.98 chrome . I think this will solve your problem…

chrome version 71.0.3578.98

1 Like

Thanks God for this!

1 Like