Chrome Click Event Failing

Configs: Chrome Version 72.0.3626.96, Chrome Extension Version 9.0.6821, UiPath Version 2018.4.3

Attempting to Fire of a button click event to do other things, and failing to run code from the click event. When looking at the browser console, am seeing errors (left the uipath extension initialize logging):
********* Browser Console*******************************************************
ContentLoader.js: content scripts loaded from existing codemap
ContentLoader.js:40 InitializeContent: message.version: 6929
VM20:3989 CustomidCache: initializing customId cache
VM20:4076 InitializeImplementation: installing input event monitors for for tabId=2
/favicon.ico:1 Failed to load resource: the server responded with a status of 404 (Not Found)
welcome.html:1 Error in event handler: ReferenceError: ComputeCustomIdWithTab is not defined
at eval (eval at InitializeContent (chrome-extension://dkgencfabioofgdmhhjljpkbbchbikbh/ContentLoader.js:44:14), :3560:8)
at DismissReturnCallback (eval at InitializeContent (chrome-extension://dkgencfabioofgdmhhjljpkbbchbikbh/ContentLoader.js:44:14), :3949:4)
at eval (eval at InitializeContent (chrome-extension://dkgencfabioofgdmhhjljpkbbchbikbh/ContentLoader.js:44:14), :3932:5)
End Browser Console****************************************

I’ve noticed on the support forums that the extension is a little problematic, some solutions cite using only 1 tab to overcome whatever issues with the extension, which didn’t work for me.

But in looking at the browser log when i only have one tab open, the extension initializes to TabID=2
VM20:4076 InitializeImplementation: installing input event monitors for for tabId=2

So i tried to create a new tab, but each tab would only increase the tabID by one when initializing. Seems odd, would think that it would either start with a 0 or 1, even if somehow it’s referring to some virtual dom. Even if it did that, the fact that i add a tab and it only increments by 1, am thinking that it can never find the button click event, because it’s looking for a tab that technically doesnt exist (some type of index out of bounds error). The error messages fire off when i click the button, so it’s finding the button click somehow, it just can’t fulfill whatever connection back to the robot it has to perform.
The function/line that it’s failing on:

Plugin Code ContentLoader.js**********
function InitializeContent(message)
{
console.log("InitializeContent: message.version: " + message.version);

try 
{
    eval.call(window, message.contentCode);
    g_csLoaded = true;

    if (chrome.InitializeContentImpl) 
    {
        // hook for implementation dependent initialization
        chrome.InitializeContentImpl(message.tab);
        chrome.InitializeContentImpl = null;
    } 
    else 
    {
        console.error("InitializeContentImpl undefined");
    }
}
catch (ex) 
{
    console.log("OnContentScriptLoadRequest failed to evaluate content script " + ex);
}

}
End Plugin Code ContentLoader.js************

Any insight would be greatly appreciated! It does work without incident with IE, however, with IE/Edge ultimately going away, really don’t want to invest developing on that browser. Thank you!

1 Like

Hi @rhibbert

Could you post a sample, shareable project that causes the error?
Also, what error is thrown in Studio?

Also, here’s a troubleshooting guide for the chrome extension issues:
Installation:


Troubleshooting:

1 Like

updated code, used google in the event for some reason my local web app was potentially causing an issue, same error:

Main.xaml (7.4 KB)
project.json (633 Bytes)

Hello @rhibbert

We have been experiencing the same problem since the upgrade of version 2018.3 -> 2018.4. The problem obviously comes from the UiPath.UiAutomation.Activities package, because it works very well under Chrome with the version of the package 18.3.6897.22543.

Have you been able to find a solution?

Thank you.

Still working on it, may have to dip into IE to handle the event in the immediate term, if everything else works fine, that unfortunately may have to be the workaround if it is something that may be addressed in a future release. I can always modify the event to monitor for a chrome click event later.