Checking Project for validation errors gets stuck

hey guys. it’s weird to say this but I’m “glad” so many other people started to experience this and the support team is aware of it now. Latest I’ve heard from our request was that they are aware of the issue and will possibly release a fix with the next update.
We decided to just push through it until then (as soon as it’s stuck at that 90% loading bar for more than 5s we close and reopen the Main.xaml, because we exhausted all the options we could think of that might’ve triggered this. We even tried minimizing the rules required for the Analyze Project to check but it still froze
We noticed that if you save the project first before debugging or starting it and wait a second or two, it happens less frequently than just starting it and let it automatically save and then run.

@PBetoRPardo whenever you press the Run, Debug File or Run File button, the project is saved and then the Analyze Project function kicks in automatically and that’s where this freeze happens. You would experience the same thing if you click the Analyze Project button prior to running the process.

Thanks everyone for bringing activity to this and thanks @loginerror for the update.
Hopefully we’ll have a fix soon.

EDIT:

Good news, the latest update came with a fix for us :slight_smile:

Will test it this week. Hopefully we got rid of that bug for good.

3 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.