Checking Project for validation errors gets stuck

Nope. All my projects are on a local folder.

I get the problem on every change. I can run the robot as long as there are no changes to the robot :sob:
A reinstall did not solve the problem

1 Like

For me neither. Even reestarting the machine, or cleaning temp uipath files dont got any results. I Guess its something related to 22.4 or maybe with the System package.

Do you have all the proper Microsoft Visual C++ Redistributable or .NET Framework packages installed for your OS?

I have checked my system requirements and so far everything is fine. This has started to be a problem as we have noticed it happening on other computers and virtual machines. I really hope they solve it…

Hi. Here is what is happening when I get this and how I fix it. There is a folder inside the main folder with other robot files, so it is checking every robot file inside any sub-folder in the main folder and taking forever. What I do is, the other revisions of the bot are in a folder named _Notes, so I just drag the folder named _Notes to the desktop, publish the bot, then drag the _Notes folder back afterwards. This takes the checking from 15 minutes to 2 or 3 seconds.

that’s not the case for me. I have a project with only two files (and the defaults ones that are automatically generated), no sub-folders, and the problem persists.
In fact, at least for me, there’s not a problem with “slowness” in the checking, but a total freeze of the studio.

Hopefully someone from @uipath will answer soon as this is really frustrating, and as other people mentioned - it does not help to reinstall.

@loginerror do you know if this is a known issue internally and something being worked on?

Hi @Obsev

Could you please confirm the version of Studio that you are using and whether it would be possible to share a sample project that still reproduces this issue for you?

1 Like

Enterprise 2022.4.1

Any project after you debugged it few times. I just tried to create a new project using template “Robotic Enterprise Framework” and after few times it starts to freeze/take long time to initiate debugging.

1 Like

Thanks god we has somenoe from @uipath aware of this.
Unfortannely Uipath support just keep us running in circle until wecant handle anymore and stop bothering.

Thank you all. It looks like the issue has already been spotted via the Studio feedback form submission and is scheduled for a fix with the upcoming release, and together with a patch for 2022.4.

For some context, see the below info on how our team managed to reproduce it (to be able to accommodate any workarounds in the meantime)

To reproduce this issue, it is necessary to have the Main.xaml file opened.
Modify any activity from Main, and without pressing Save or Save All, directly press “Analyze project“.
The validation triggered by saving the file will intentionally block all validations triggered by “Analyze project“, leading to making these validations to block forever while waiting to complete.

2 Likes

Thanks @loginerror. Again you gave us a solution faster and better than the support :joy:

Could you share with us if the problem is related to something especif that we can avoid the use? A specific activity, or a dependency? An Import maybe?

1 Like

No problem. See my edit to the post above :slight_smile:

2 Likes

Is there an alternative solution or do we have to wait for the update at the moment ?

You could stop using the button “Analyze Project” while Main.xaml is open. Or first you save Main.xaml and then you click on Analyze. Dont let the Studio save by itself.

Hi @loginerror , thanks for your quick reply on this.
I was wondering the following:
I can also reproduce the same issue while trying to run a saved test case in debug run without opening main.xaml.
Is this also in scope by the development team?

I can’t fully understand, I don’t use the Analyze Project button, this happens as soon as I press the Run, Debug File or Run File button, which for some reason Checking Project for validation errors gets initializes first and that’s when it gets stuck.

hey guys. it’s weird to say this but I’m “glad” so many other people started to experience this and the support team is aware of it now. Latest I’ve heard from our request was that they are aware of the issue and will possibly release a fix with the next update.
We decided to just push through it until then (as soon as it’s stuck at that 90% loading bar for more than 5s we close and reopen the Main.xaml, because we exhausted all the options we could think of that might’ve triggered this. We even tried minimizing the rules required for the Analyze Project to check but it still froze
We noticed that if you save the project first before debugging or starting it and wait a second or two, it happens less frequently than just starting it and let it automatically save and then run.

@PBetoRPardo whenever you press the Run, Debug File or Run File button, the project is saved and then the Analyze Project function kicks in automatically and that’s where this freeze happens. You would experience the same thing if you click the Analyze Project button prior to running the process.

Thanks everyone for bringing activity to this and thanks @loginerror for the update.
Hopefully we’ll have a fix soon.

EDIT:

Good news, the latest update came with a fix for us :slight_smile:

Will test it this week. Hopefully we got rid of that bug for good.

3 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.