Check Box selection

I have created all teh steps provided by you but while executing the second step getting error shown below.

selector is second step is
html app=‘chrome.exe’ htmlwindowname=‘scalemaintenance’ title=‘Scale Maintenance’ />
<webctrl parentid=‘ctl00_main_cboServiceAreas_ListBoxSelectItems’ tag=‘DIV’

1 Like

Try it in IE browser buddy @shashank_dullu
we have an issue with this in chrome as per this

Try this and let know buddy @shashank_dullu

Did that work in IE buddy @shashank_dullu

Nope got some error while login into the application .

Message: Cannot find the UI element corresponding to this selector:
webctrl id=‘txtUserSignon’ tag=‘INPUT’ name=‘txtUserSignon’ type=‘text’

Exception Type: UiPath.Core.SelectorNotFoundException

1 Like

Buddy @shashank_dullu
Kindly make changes with all the full selector in app attribute because previously we were using chrome and now we are using IE so kindly check whether all the full selectors are changed with IE as well, now the issue with find text position is clear, it is something different only with application, kindly check that and make changes in the selector buddy.

BUDDY @shashank_dullu
as you can see here
webctrl id=‘txtUserSignon’ tag=‘INPUT’ name=‘txtUserSignon’ type=‘text’
it seem like some error with sign in credential details input, kindly check with browser used and also make changes with click or type into activity with the selectors as well buddy @shashank_dullu

Try and let know buddy, you were almost done, let sort this out

Any issues still buddy @shashank_dullu

Sorry buddy there is some other issues as it is not working for IE.After changing the selector.

no worries buddy were you able to select the text as element in chrome buddy

if so we can use find element instead of find text position, and pass the variable to selector for the attribute that indicates the text we were searching say for example if aaname attribute denotes the text we want to search replace the value of that attribute with variable like this
aaname = ’ "+ variablename + " ’
in the selector buddy that would work for sure if we are able to select the element individually

Try this and let know buddy
Cheers @shashank_dullu

@Palaniyappan - Buddy is there a way in which I can share my Sequence and you can see as it seems I am going to a wrong direction.

Yes buddy kindly send the xaml buddy @shashank_dullu

@Palaniyappan - Buddy please find the attached below .let me know if you require the flow as well .
Swap.xaml (43.1 KB)

@Palaniyappan - buddy try this one . this will take to directly to that part where I am facing the problem.
Swap.xaml (43.8 KB)

Buddy it was due to this message box

and message box can get only string type of input were the one you gave is of type uielement buddy
so remove that message box and execute it buddy
Try and let know whether this works or not buddy

I could not see that error at my end

1 Like

No worries buddy,
Then may i know what was the error you were facing with the workflow buddy

So when I run the XAMl file .
At the message box(Outelement) it will display some value i need to check value in the service area box and check that check box and uncheck the previous checked box.

1 Like

NO buddy messagebox will take and give only string type of value, where the outelement is of type UIElement, so kindly remove that message box and run buddy that would work

Cheers @shashank_dullu

1 Like

Okay Buddy .

I have removed the Message Box . if you refer my update Xaml file.
Now the thing is when i am running the bot. the first input will ask for store no - enter 140 second will ask for scale id - enter 5 . and third input will ask for department - enter Bakery which will be unchecked . and after 3 rd input dialog box .the service area box should check the bakery check box and uncheck the previous check box. but now i am getting the error at click image activity with error mentioned below.


and the area where i need to check the input of inputdialog 3 and uncheck the previous check box .


Updated XAml file.
Swap.xaml (41.0 KB)

Kindly install windows 7 update KB2533623 this problem will get resolved buddy @shashank_dullu

for more information check here buddy Click image doesn't work - #8 by slammer
Kindly try this and let know buddy, we can still sort this out

Setup not applicable to my computer. :disappointed:

Even tried in google for the same error but no resolution