Check :Attribute not supported by the current UiNode

I know that this is repetitive topic but I am still unable to find the cause and concrete solution for this.
While using ‘Check’ activity to check a checkbox, I get an error saying "Attribute not supported by the current UiNode ". So as per some previous posts, I replaced 'Check; with ‘Click’ activity, it worked perfectly but as soon as I enabled Simlulate click, it stopped working, it doesn’t give any error, simply skips the checking step.

The selector I am using in click is dynamic selector.

Any suggestions please


Could you please open UiExplorer, indicate your checkbox and show us a screenshot of Property Explorer window?

There is a possibility that Set Attribute activity will help, however you need to know which property is responsible for “checking” the box.

I think your hint is correct, this chekc box doesn’t have any property which says whether it is checked or not, usually I have seen properties like eg. ‘Check’ which will either be true or false and so only it was not working for Check activity. It didn’t work for simulate click as it was clicking outside, anyways I narrowed down the selector pointing to the box and it works now for simulate click.

Thanks for the guidance.