Chatbot connector issue in orchestrator


While executing uipath chatbot there exist an issue in mapped process in uipath chatbot.

I had created agent and intent in dialogflow. Then agent is connected to uipath chatbot. Also orchestrator is connected to chatbot. Then uipath process is published and mapped into intent in uipath chatbot.

After all these steps , when chatbot is tested in web, its showing an error like “Something went wrong, please try again later.”
input parameter is of type string and input argument is also of type string with same name.

After this,When I check orchestrator , the job is still showing pending allocation for user and robot.
How to solve this issue?

Do you have any idea about this?

@rifnanahas - you’ll need to make sure that you have unattended robots connected to orchestrator in the orchestrator folder specified during setup for the job to run.
A way to verify this is to go to try and start a job manually in Orchestrator. To do this, go to the Jobs section in Orchestrator, click on the start button, select a process and a robot to run it on. If you don’t see a robot in the list (see screenshots here: Triggers no search robot? - #4 by codemonkee), you’re going to need to add an unattended robot to your folder

Please let me know if you’re able to start a job from orchestrator, but not from your chatbot

1 Like

@Karan - Even I am also facing the same issue (Something went wrong, please check your bot designer) But when I start a job manually in orchestrator it works fine and also I mentioned robot type as unattended.

1 Like

@dinikokila_k - I’ll need more information to help, but one potential reason might be due to parameter mapping. To confirm whether this is the case, can you please share screenshots of:

  • Parameters of the dialogflow intent

  • Input argument list of the mapped process

If it’s going pending for allocation you have to configure the unattended robot. Go to cmd and type whoamI. You will get domain/username. Password should be your computer pwd. Let me know if it works.


Thanks for your input.

@Karan @ashishsinha1504 I am trying to map a single process to multiple intents.
For the first intent process run successfully and for the second intent I am getting below error

Something went wrong, please check your bot designer

Process mapping for 2nd Intent

@gaurav.tiwari - I suspect this is due to incompatible entity and argument types. Can you share a screenshot of the entity types of your Dialogflow intent parameters, and the input arguments of your mapped process?

Please let me know if you need any more details.

Thanks for this @gaurav.tiwari.

The issue might lie with the AppointmentDate and AppointmentTime parameters.
Looking through the Dialogflow system entity reference, the output format for and sys.time is String in ISO-8601 format, but the input arguments in your process are of type DateTime for both. Changing the argument type to String, or changing the entity type to sys.datetime might work

Hope this helps :slight_smile:

Hi @Karan I have tried changing the input argument to string in UIpath but it is giving runtime error because of type mismatch for Appointment Date & Appointment Time parameter.

Then I also tried changing the Entity type in Dialog Flow to sys.datetime but that is also sending empty string in case I don’t provide the value in bot.

I also tried changing the input parameter in UIpath to Nullable DateTime but it didn’t worked.

Please suggest what can I do to resolve this issue?

@gaurav.tiwari - in this case, I’d recommend using type Object for the input arguments that map to these dialogflow paramters, and then accessing the user provided values through it.

Hello @Karan

I am getting the same error since 2 days. I tried deleting everything and starting all over again

Before 2 days same settings were working.
Now the chatbot is working in Dialogflow test Chatbot but not in the web test view of

Please help me with this.

Thanks in advance

Error : “Something went wrong, please check your bot designer”

Hi @alpharobot - are you seeing this issue in another browser like edge, or is this a chrome only issue?
If this is only occurring in Chrome, it might be due to the samesite flag being enabled.
This is a known issue which currently requires the flag to be disabled: Tips and known issues

hi, I am doing a basic integration of dialogflow with UIPath. Used an unattended robot which runs fine from the orchestrator directly.
I am using sys.any for name and location which map to string arg in uipath.
Though i have mapped the second intent to the process, i still get “working on it” in the first intent itself. i think the contexts are not getting reset here, and hence the issue. How do i resolve it?

Also Where do i see the logs for dialog flow or connector?

Hi @RGudi - The chatbot connector to Google Dialogflow at is deprecated and will be turned offon Oct 24th per: Deprecation Notice: The Chatbot Connector Preview is deprecated effective July 1st ‘21

I’d recommend using the options provided in the notice to integrate RPA with you choice of chatbot instead