Characters missing when using "Type Into"

Using “Type Into” with Quickbooks application, randomly in the process, characters will be missing. I am transferring strings from an Excel spreadsheet into Quickbooks. For example a name will go from “Mike Smith” to “Mke Smith”. I have slowed the DelayBetweenKeys down to 150ms, but that has not helped.

Did you try Checking Simulate Type? Or unchecking SendWindowsMessages?

Since WindowsMessage is checked and No element indication for the activity, do you think “i” is going as a hot key? or Mike Smith is just an example?

No this is happening with different letters, as well as numbers. I checked “SendWindowMessage” because there is not a constant target. In my workflow, movement around QuickBooks is done through tabbing and input is put in a row at a time. If “SendMessageWindow” is not checked I get error messages telling me a target has not been selected.

Hi @walkermckenzie

I too faced same kind of issue while using TYPE INTO activity in SAS Application, where some characters got missed randomly while typing. Then I tried to copy the text into textbox by copying the value in clipboard Set To Clipboard and pasting it by “CTRL+V” via Send Hot Key Activity. Try this in your workflow ,it may works in your case. But for this post ,Characters missing in TYPE INTO activity i didn’t got any solutions, hope i ll get it here.

Regards,
Ranjith.

2 Likes

I see this is a slightly old thread but I see there was no solution. I just hit this yesterday for the first time.

We are using Type Into to send price information into out ERP (through a terminal window). We send one price then tab to the next field and type another price. Occasionally the first price has the end characters cut off and the tab is received too early so instead of:
1080 tab 2599
we get
108 tab 2599

Doesn’t happen often. I’m going to try tadd a delay between keys but it seems strange that key presses are not sent in order.

Hi @bobpeers,
I know this should be too late for your question but I’m writing this for other users facing the same situation.

Have you tried [set to clipboard]→[send hotkey(ctrl+v)] as written above?
If there’s any default value set to the input form,
then add [send hotkey(ctrl+a)]→[send hotkey(delete)] before [set to clipboard]→[send hotkey(ctrl+v)]

you can also use Set text activity

1 Like

Hi, thanks for posting. This technique has worked for me.

1 Like

I’ve also seen this issue on a text field on an internal system. Sometimes the first letter is sent as a lower case letter whereas the rest are sent as capitals. Sometimes the first 2 letters are also missed off. Fortunately, it is a search field, and as I am using other search terms too, I am able to find the correct result.

This worked for me! Thanks

So we can’t rely on Type Into activity to input the correct text?
What if this will happen to a robot that sends money into an account? Why this activity still exists if it can type wrong text?

1 Like

Estoy presentando el mismo problema con esta actividad, veo que nadie ha logrado solucionar el asunto.

I have experienced this problem today while performing Demo Data Scrapping project from Google Search -> Videos.

In my case problem is solved by changing the WaitForReady = COMPLETE for Type Into Activity. Hope this helps someone.