Change Pending start delay

orchestrator
jobs

#1

Hi all,

Does anyone know how to change delay before a Pending job gets started?
Haven’t found anything and I’m wondering if it’s somewhere in any of the configs.

Currently it’s a consistent 15s, which is way too soon for some environments, as the logging out at the end of the previous job takes longer - which leads to “Unexpected termination” issues, essentially making the Pending feature useless in that environment.

Regards,
Andrzej


#2

Hello,

We don’t have this functionality and we cannot implement.

This problem occurs when the robot machine doesn’t have enough resources and the login session takes more than 30 seconds (this also applies for mstsc).

Can you give me more details about the environment (os, hardware configuration, firewall, process, schedule / or manual job,etc).

Thanks


#3

Interesting. Any chance this could be changes on system level (I’m using console sessions, RDP sessions are out of the question in that project)?

These are always scheduled job runs. Asking around, it happens on different environments (completely different configurations, hosted in different DC’s operated by different providers).
Common things are Windows Server 2012R2 and that a previous job ended soon before (either new run was Pending, or there was a short break between them).

While it might not solve the issue, I’d still be interested in changing how long a Pending job starts before it tries to start, as in 90% of the cases in the environment I’m currently working on it will not work as-is. The job that is running first has variable execution time, as it involves human interactions, so it’s not feasible to adjust the schedules to give an artificial delay there. And the first process is really light on resources used in it’s last ~10 mins (building the queue), so it has to be the logging out routine.

Regards.


#4

Ok, so do you have something like this:

  • first job looks like a front office robot with human interaction (this is started from robot tray or Orchestrator?)
  • you have a fixed schedule for a back office robot, if the first job is not completed the schedule will create a Pending job and the job will start when the first job is completed (right?)

Things to try:

  • If this is not a HD environment change logintoconsole: true (in uipathsettings file)
  • You can start the first job from robot tray (front office with human interaction) this way when the job is completed the robot will not log off
  • The back office robot (from Schedule) will start in the same session

#5

Hi Andrei,

No, it’s not a front office robot - it takes an excel file from a predefined location, interprets it’s content (it’s a collection of free text task descriptions) and saves it to a different location. Then waits for a human approved list in a predefined folder. It may sound “weird”, but these are process requirements that are non-negotiable.

This is running on console sessions, RDP rights are not granted at all. Starting from tray is not an option, as humans don’t have access to the servers robots are running on and it starts in the middle of the night anyway, so there will be noone to trigger it anyway.

Yes for the second part - it’s a fixed schedule with some leeway, but sometimes authorization takes longer than expected and the new job goes to pending.

We really can’t change much with the settings, as this is a highly controlled environment and as far as this issue goes, nothing will be changed without a couple of months of negotiations (I’m dead serious).
The only issue I’m having is that the job that is Pending sends a start command too soon - 15s after previous one finishes. Since by default if a robot started the session it will logout at the end, it’s a very low time window for the server to free up all resources (especially if the next job uses the same user).


#6

I see. I will try to replicate the process on our testing environment and find a solution.

Please give me the hardware details for that robot machine.