Can't zip file which title has Chinese characters

I have a folder, which each sub-folder of it has password-protected PDF files in it. Now I want to use “Compress/Zip Files” activity to zip each sub-folder, my workflow is in the picture.

But when I run the workflow and get the zip file, I can’t find the PDF files in it (but the size of the zip file is the same as the folder, which is correct). But if the PDF files are unprotected, everything runs correctly and I can find them in the zip file. So I wonder How can I zip protected files? By the way, I also want to know how to zip into 7z file.

Hi @N_Du

Welcome to UiPath community!

Were you able to manually(without automation) zip the protected files?

HI Usha,
I can manually zip them.

@N_Du - Did you try giving the password in the password field. You can test this with single file and see how it goes

I’ve tried, but it didn’t work. It’s empty when I open the zip file, even though I zip a single file and give password.

@N_Du Did you try with the below package


I cannot find this package in the Template tab, where can I find it or how can I install it?


  • Click Manage Packages

  • Click on All packages. Search for that package and install

Hello @N_Du,

it is not necessary (and not really recommended) to add an additional package to solve your requirements.

Try this approach:

Set the checkbox Include subfolders and use in Compress the attributes Name and FullName. I tried it and it works as expected, also with password protected PDFs.

Could it be possible that your PDFs are protected against access from another user or do you work in both cases with the same? Otherwise open with a right mouse click on the file the property dialog and open the security tab to change the rights.

You can find a tiny manual how to use 7Zip here.

Best regards

Hi @StefanSchnell @ushu ,

I find out that it’s not about password-protected or not, but it seems that it’s because my PDF files name include Chinese so they can’t be zipped. I delete the Chinese in the file name and everything runs as expected. Sorry for making mistake.
So is there any method to zip the file which includes Chinese in the file name?

1 Like

Hello @N_Du,
interesting use case.

I tried my approach with Chinese characters in the file name, and it works without any problems.



As far as I can say it makes no difference. Which compatibility mode do you use for your UiPath project, Windows - Legacy or Windows? Which Windows version do you use, Windows 10 or 11, or an older one? Which UiPath version do you use?

Best regards

Thank you for this topic. I put a bug in our issue tracker about that activity not handling Chinese characters properly.

1 Like

Hi @StefanSchnell @loginerror
I am using Windows 10 and the UiPath version is Studio 2022.4.4. I tried again this morning and it still not work on file name with Chinese characters.

1 Like

I can confirm that the latest System package 23.10.x (latest right now is 23.10.3) fixes this issue, as long as you set the encoding to UTF-8.