Can't use selectors after app update. Oracle/OCS HR/ALOE

Hi,

We are building solutions on application called “OCS HR”.
The application is challenging, as there’s no selector for items from “drop down” menu.
But, we manage to make it work through keyword typing while the list is opened.

However, upon the latest update, the application becomes more challenging.
Almost all selectors are no longer working.
When bot goes to select a “row” of the items, the whole panel is selected.

This is before update (mouse cursor is placed in the grey box on the right side of “Position” and the position is selected which bot can obtain text)

This is after update (mouse cursor is at the same place, however the whole panel is selected)

This happens to almost all the GUI of the application.

I’ve tried adding Java extension.
But so far no luck.

Any help is much appreciated!
Thanks!

Hi, I am also facing the same problem with the selectors after application update.
Any help is highly appreciated!

Thanks in advance :slight_smile:

Hi @RUPALI_PATEL and @hellitonwoo,
I am also facing same issue after update of application.
Assistance is appreciated, on the identification of selectors apart from using image based activities, as image based activities may cause much efforts in redesigning of bots.

Please let me know if any more information needed.

Hi
In that case did we try with SEND HOT KEY activity with key as tab to navigate across the fields where we dont need to select any element and just mention the hot keys alone
even to type once after reaching the field we want after using n number of hot keys in send hot key until the field is reached, use TYPE INTO activity with only the input string and not selecting any element, that would type in the string we want
Cheers @hellitonwoo

1 Like

Hi @hellitonwoo,

  1. Are any scripting setting changes done with upgrade, if you can check with the application owners… and if possible revert those settings.
  2. It may happen if user have given different privileges now, try running uipath and application as administrator.
  3. Get in touch with Uipath team, they can give some details in which case selector stops working.
  4. If nothing works last option is to do image/ocr based automation, but yeah that will be a whole coding change and will take time.

@loginerror if you can take a look here that would be great.

1 Like

@Palaniyappan
Thanks a lot for offering help!

As the bots were in production for quite a while, it is a massive change if we use other methods, like send hot key or image based.
Also there’s a risk of using “send hotkey” as it impales data validation part of the process (we can’t make sure the typed in text or chosen options are what we want).

1 Like

If the process and elements are stable then using SEND HOT KEY is more reliable and easy to work with
@hellitonwoo

@SaurabhDisawal
Thanks for lending the hand!

We’ve contacted the support and like you said, there are things tried:

  1. Check if UiAutomation is the updated or whether it helps to use downgraded/beta version
  2. Check the application level, and before/after the update, this app OCS is both in “elevated” level
  3. Check the running environment. there’s no change
  4. Check the services of the app. So far, we discovered some .DLL files are not running when the new version OCS is executed. But that’s it, and we can’t make them run with the app. And we don’t know if these .DLL files are responsible for the issue

@RUPALI_PATEL and @chaitanya.kulkarni, what about you? Any luck?

1 Like

@Palaniyappan
We will definitely give it a go. This looks like our second best options so far.
Thanks!

1 Like

Hi hellitonwoo,

I tried with below options:

1.I was able to get the selector and interact with older version the target application(oracle application) but there was a major upgrade to the target application post which I are not able to find any selector and perform any action.

2.I tried with different mode of Uiframeworks but no result.

3.Verified from task manager that both version of target application are running as elevated. Tried to open UiExplorer as admin, no help.

@Palaniyappan : ‘Send Hot Keys’ only seems the workaround for this issue, but as you said it sounds risky due to lack of validation.

Even thought of other two options like:
1.Image based activities: Not completely reliable.
2.Computer Vision activities: Reliable, but need to update the license.

@Lucas.Pimenta and @aksh1yadav : Would you guys like to add any inputs for above issue?

1 Like

@hellitonwoo @chaitanya.kulkarni @RUPALI_PATEL

Hi, looks like an important UI architecture change for the Oracle app. Can I know which application version was working fine and which version is not working anymore? Also, what UIAutomation package version are you using? Thank you

1 Like

@gheorghestan
Sure.
The version 23.01 or 23.02 works and the version 24 no longer works.

We’ve tried UiAutomation from 18.4, 19.4, 19.7, 19.10, even 19.12 Beta.

Also got support to look at the issue. And we were introduced a tool https://accessibilityinsights.io/, which helps detecting whether the Ui Elements can be found.
It confirms that the version 24 blocks many things to UiPath.

BR
Hao