Can't use nuget package - NU1202 Error

I’m trying to use a custom Nuget package in my project but everytime I try to install it, it fails as follows:

I already:

  • Checked .net Framework’s version on my machine.

  • Installed every version of .Net Framework runtime, dev tools and target platforms from 4.6 to 4.8 (4.6,4.6.1,4.6.2,4.7,4.7.1,4.7.2,4.8),

  • Verified in Regedit that the latest version is 4.8 (the most recent) 528372

  • Tried with different nuget.exe versions to generate the nuget package

  • Verified and no, there’s not a single error in the function library coded in C# (Visual Studio)

  • The nuget package is generated with no errors

  • Tried with different project types: Windows Legacy, Windows, Cross platform, Library, Process…

  • Reinstalled UiPath Studio

  • Downloaded the latest Community Version 2022.4.0

Have anyone come across this type of issue with a .net 4.7.2 Code Library? Or any additional ideas on how to solve it?

Is there a way to force UiPath to take 4.7.2 as its base framework?


Just to get more clarity, Is this the package which you have developed? Or you are using the package from market place which someone else has developed.

Hi Rahul

It’s a function Library that I coded.

In Visual Studio there are no warnings or errors, and this same function Library can be successfully consumed in other c# projects and other RPA tools.

Hello Oscar,

It looks like there is a mismatch in the .net version. Please check whether the below doc will help to check the .net framework version.