Can't Start workflow from .bat file

Hi there.

I’m trying to execute a workflow from a .bat file and here is my command in .bat file:
start “C:\Users\wendyw\AppData\Local\UiPath\app-19.12.0-beta0061\UiRobot.exe” /file: “D:\wendy\UIPath_Projects\Platform_Test\Robot2_NotePad\Main.xaml”

But when I clicked the.bat file , the uipath studio opened without executing the process。 I checked the posts before like this one Start workflow from .bat file - #4 by Rammohan91 but no lucky. I tried run the command in cmd, and got this error.



I guess you are using latest version of Uipath Community Edition.

And now we can schedule and run the BOTS from UiRobot system tray and no need of any Batch file or windows task schedulers. Please check below thread to know more about this.

Instead of /file use --file.

@ lakshman thank you . yeah, I do use latest version and l learned we can schedule the time in system tray, but in my case , I still need .bat. anyway, thank you !

1 Like

tried but failed :sweat_smile:

@Wendy_01 kindly try this:

“C:\Users\wendyw\AppData\Local\UiPath\app-19.12.0-beta0061\UiRobot.exe” -file “D:\wendy\UIPath_Projects\Platform_Test\Robot2_NotePad\Main.xaml”

The command should have an execute also before --file

“C:\Users\wendyw\AppData\Local\UiPath\app-19.12.0-beta0061\UiRobot.exe” execute --file “D:\wendy\UIPath_Projects\Platform_Test\Robot2_NotePad\Main.xaml”

1 Like

two lines?
it opens the studio. but i wanna run the process instead.

perfect! it works! thank you so much! @KannanSuresh

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.