Can't run robots on High-Density Configuration with loginToConsole = false unless RDP is opened (Waiting for execution to start)

Hi all,

Update

I’ve successfully setup an Orchestrator server along with a High-Density robots server. I can trigger/schedule a job normally for 1 robot with my RDS session off with loginToConsole = True. Though, when using loginToConsole = False to run multiple rubots in parallel, I can only do it with both of my RDS sessions opened. Whenever I try to do with them closed, they stuck on “Waiting for Execution to Start” until they crash.

Here is some usful info:

  • The two processes are running into different users within the same server (High-Density Configuration);
  • Both are running on a “NonProduction” environment. Already tried “Unnatended” as well;
  • 2 runtimes are set for that machine;
  • My server got the Enterprise Edition running with the Trial license with UiPath Service running on background.

s

Hi @Renan_Kataoka,
We are facing issues when running the bot on High Density server also. Did you have any luck on the above query? Were you able to resolve the issue?

Hi @RiteshJain1411,

We’ve spent plenty time trying to solve the problem, but the real issue was that we had our RDS licenses revoked without our knowledge.

If the same happens to you, you will only be able to open RDS Connections with the “mstsc/Admin” command (only mstsc won’t work).

Regards

Hi @Renan_Kataoka,
Thanks for the quick reply. I can login via mstsc, no issues on that and we have our RDS licenses.

The issue for us is, when we are logged in the HDR server with the robot user and then run the bot from the orchestrator, then it works fine.

But when we run it in unattended mode (no one is logged in) it fails with a timeout error.

what are your robot settings? and how is your experience running the bot on HDR

Ritesh,

Actually the company we are working on changed our licenses to frontoffice, so it’s been some time since we don’t mess with HDR. Though, at that time, we succeeded running the robots in HDR.

Here are some suggestions:

  1. Check if SuppressWhenMinimized is enabled:
    https://robot.uipath.com/docs/executing-tasks-in-a-minimized-rdp-window

  2. Make sure UiRobot.exe service is running on the background

  3. Maybe you are getting timeout errors due to proxy not being configured on UiPath config file. It is used to download packages and depends on the network you are using: https://robot.uipath.com/docs/redirecting-robots-through-a-proxy-server

  4. There is a Windows environment variable that handles UiPath timeouts: UIPATH_SESSION_TIMEOUT. I would try to increase this value if none of the past advices worked.

Hi @Renan_Kataoka

Thanks for the help with the links, we tried all the options but no luck. We are not able to run the bot when we are not logged into the session. We have raised a UiPath ticket too.

Wanted to check with you, which windows server are you on? and do you disconnect the session for the bot to then log in or do you sign out for the bot to log in

We are on Windows 2016 server for HD robots.

Out of curiosity, when you log off and log back in manually, do you see the Start Screen or the Desktop? Because if the Start Screen is showing up this will cause your bot to timeout at the start no matter what. You will need to suppress this setting with a fix to the server. I think this was an issue on Windows Server 2012 though, which was fixed for Windows Server 2012R, if I remember right.

Hi @ClaytonM,
Yes, the start screen/menu shows up when we log back in. Do you remember what the setting is?

We are on windows 2016 server

If I remember right, I think it’s the Desktop Experience feature. Go to Server Manager > Manage > Add Roles and Features, then look for User Interfaces and “Desktop Experience”. I can’t remember if it’s supposed to be uninstalled or installed though. If it’s not what fixes the login to the Desktop, then you might try searching online. Let me know if you still can’t figure it out.

Regards.

Hi Team,
Thanks a ton guys for the hlep @Renan_Kataoka, @ClaytonM appreciate it. The issue is solved. Our robot service was not up and running. Once we started it, the issue was solved.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.