Can't recognize element in the robot

Hello guys

I have a process that need to get text from search results in notepad++, in my local studio I can get the text every time - but when I run it through the robot its never rcognized it.
I trying to play with the delay but its not this.
Can someone think what should be the problem ? its only this element making the problem
I add the picture from my local

Could you show us your selector?


You were able to extract the text from your local studio(local studio also runs through robot), but not through the robot? Can you explain about this a little more.

Also, when it was not able to extract, does it showing any error

Well, I run the process throw the orchestrator and open the robot PC to see the run and when its come to this point its act its jump the Not Appears message box
Also the orchestrator show this error :

Depending on the result, the last line might change. Test to edit it and add a wildcard:

<ctrl name='Search*' role='client'>


Doesn’t work on the robot but works in my local studio

What if you skip the ctrlid?

<wnd app='notepad++.exe' cls='Notepad++' title='new 1 - Notepad++' />
<wnd cls='#32770' title='Search results*' />
<wnd cls='Scintilla' title='Notepad++' />
<ctrl name='Search*' role='client' />

Again Doesn’t work on the robot works in my local studio

Ok, that’s weird. The next logical step is to start Studio on the robot machine, run the process until it fails and then check how the selector differs from the one on your local machine.