Can't find selector while running script with 2018 version

18_1

#1

Hi @uipath,

Recently, I’ve started to experiment the possibilities of designing an automation for a software that collect user data and put them in SQL database.

And was hit by the stone right away, finding out that 2018CE can’t work with the software at all.
So, digging around, found that the 2018CE should have the Admin privilege.
Then I turned on that.

After enabling “run as administrator”, 2018CE can find some selectors (finds the UI elements of the interface, but not all of them) when I design the workflow. But if I run the script, it can’t find selectors, none of them.
So, I’ve tried to use OCR or screen scraping, none of them work, it’s like the 2018CE can’t recognize what’s on the screen.

Then I went on trying on another computer with 2017CE, turned out that the 2017CE can find the selectors (finds the UI element of the software) when designing the script and also when running the script. (2017CE is also ran with administrator privilege)

Here is the target software webpage.
http://www.truck-scale-software.com/

BR
Hao


UiPath Studio needs to be run as an administrator