Can't Disable User License Management

I don’t have this option in community version? Is that correct?

We’re having the exact same issue. The “Enforce user authentication, disable robot key authentication” options keeps checking itself and therefore leaving the bot with no access to assets. For what I’ve read, disabling the User License Management option is the only way to make that configuration stop changing on itsown after a day or so. But I’ve been searching everywhere and it doesn’t seem to be available.

I have the same problem using the community version, we disable the option and the next day it is activated again.

additionally I follow the configuration of the documentation where it clearly says to use machine key instead of login.

so I ask you …

So the documentation is wrong?
should we use the login?