Cant connect Robot to Orchestrator

uipathrobot

I am not able to connect even after following all the step. Can anyone help?

2 Likes

@Vaibhaw_kr

Could you please show me the screenshot of Robots page in Orchestrator ?

1 Like


Here it is @lakshman

1 Like

@Vaibhaw_kr

Go to Machines page in Orchestrator and configure published robot machine name and go to view and will give one Key and paste in Machine key field of Orchestrator settings window of that machine.

And also check whether you entered correct domainName\username properly or not. To check this open CMD and enter command like whoami and same you have to enter in robots pages in orchestrator under username.

1 Like


@lakshman Are you talking about this? I have already copied and pasted it. Also my used name seems to be correct

3 Likes

Buddy @Vaibhaw_kr
the reason is
–you have the machine created and a robot as well…
–but machine is name different here like demoMachine…it should be as in your machine like this
LAPTOP-POE7OUNH
not demoMachine and this can changed in the machine tab and a edit option at the right end (BOTH SHOULD BE SAME, DONT GIVE DIFFERENT NAME)
image
–once after changing the machine tag this machine to the ROBOT YOU CREATED
CLICK THE THREE DOTS in the robot tab (to the robot you have created ) AND ADD THE MACHINE NAME WHICH GOT CHANGED BUDDY
and buddy @Vaibhaw_kr
make sure that robot is tagged to a environment, to do that a environment should be created in robot tab here, create a environment and add the robot by clicking the update or edit option at the right end of the envrionment name, click that option and add the robot you have buddy @Vaibhaw_kr
image
Then go to the robot tray disconnect it and connect again buddy, now the robot will get connected @Vaibhaw_kr
that al buddy you are done
@Vaibhaw_kr

were you able to connect now buddy @Vaibhaw_kr


I changed it to like this, and disconnected and reconnected, still showing no robots available @Palaniyappan Can you try teamviewer and check?

2 Likes

buddy did you tag the robot you have now to an environment see here buddy there is no environment, to create a environment go to robots tab and click environment tab buddy @Vaibhaw_kr and create one and once after creating a environment click the edit option at the right end of the environment name and add the robot you have buddy
image

then try to disconnect and connect buddy @Vaibhaw_kr
it will work for sure
Cheers @Vaibhaw_kr

@Palaniyappan There is no option to click to create that buddy, I just checked

2 Likes

here it is buddy @Vaibhaw_
image kr

(this is in mine buddy dont get confused with the environment name, i just tried to get you there, you can this option in yours as well buddy @Vaibhaw_kr )


Cheers @Vaibhaw_kr

Now buddy @Vaibhaw_kr

@Palaniyappan I did this and disconnected and reconnected but still

2 Likes

buddy still the machine name is not tagged buddy see
image

to do this go the robot tab click here and mention the name of your machine in the MACHINE field buddy.

Then disconnect and connect again buddy
that would work
Cheers @Vaibhaw_kr

were you able to connect now buddy @Vaibhaw_kr
or any issues still buddy @Vaibhaw_kr
cheers

Old thread, but I just wanted to point out a couple observations in the discussion that might help future readers.

  • Local Robot Service is Connected, but Status “Robot unavailable”
  • Machine “demoMachine” was set up as a Machine Template. This allows a single machine key to be used by multiple [attended or Studio] robots. The name of the Machine Template does not need to match a targeted machine’s hostname, this would be a requirement if you made a Standard Machine.
  • Robot record was created as a Floating Development Robot (Now referred to as Studio Robot). Once successfully connected the Robot would show a machine name like hostname (templatename) e.g. Hostname being “Computer123” and the template name being “Call Centre” it would display as “Computer123 (Call Centre)”. A Robot does not require to be a member of an environment to have a successful connection with Orchestrator.

Comparing the current Cloud Platform (2020.1.9) to Private (2019.10.16) there some new settings, but largely looks the same. (Setting the Runtimes for Unattended and NonProduction is new)

After creating the Machine Template you want to create the Robot Record that should match the user you are configuring the Robot otherwise it will be “Unlicensed”.

Next after configuring your local Robot Service with the proper Orchestrator URL and Machine Key, the status should switch to Connected, licensed.

image

Reviewing the Robot record in Orchestrator it should now show Available and the machine the Robot is connecting from.

My thoughts on why the original post was not working are:

  1. Platform URL, I don’t recall when Cloud was introduced having multiple Organizations and Service Sites i.e. https://platform.uipath.com/org/service/. This could be why as the original URL was set as https://platform.uipath.com/

  2. Floating Robots only work with Active Directory users according to the documentation. Based on the username laptop-poe7ounh\fresh this doesn’t appear to be an AD user. I have only ever used UiPath in a domain environment and have not directly tested a local user account in a non-domain environment.

Floating Robot - works on any machine defined in Orchestrator, be it Standard or Template, as the machine name is not relevant when creating it. Only Attended and Development Robots can be floating, and as such, they become licensed automatically when you open the Robot tray. These types of Robots only work with Active Directory users and are useful if the machine you want to add a Robot to has a different name each time it is spawned, such as for Non-Persistent VDIs. Same goes for hotseat environments, where different people are working in shifts on the same computer.

Hope that helps!