Can't check the files on FTP

ftp
studio

#1

The folder and the file in the same FTP path, “Directory exist” output true, but “Files exist” appears exception is what reason.
Test Result:
1.Test Connection:


2.Exception:


#2

I am assuming that your FTP connection activity is holding the control on main folder which will not allow another activity on the same folder to perform. So, disconnect the folder access once you get your folder exits check then create another connection for for file exists. make sure you provide different variables and not conflicting with folder connection.

Hope my inputs are useful.


#3

Thank you very much for your reply. I tried to check the file only, but still there was a timeout exception. I guess the firewall intercepts data reads, but the path is readable, so what do you think might be the reason?


#4

Please check if the file is readable or not. try to copy the file from the folder and paste on your desktop if possible.
If file allows you to copy paste then the file is accessible. also some times the file is shared by any other tool in your system. That also stops you to access.


#5

Your prompt reply moved me. But I am still investigating the problem, and hope to get your reply later, thank you.


#6

Hi Gary,

Have you resolved this issue?

I am also getting the same error on VM but locally it is working fine.

It should be some firewall issue but needs to know what to enabled there.


#7

Yes, the problem has been solved. But I don’t remember clearly, it is probably in Windows Firewall to put the Uipath right back to normal.