Cannot Trigger UiPath Robot after Update to UiPath Assistant in VDI

Before updating to UiPath Assistant, I can sign out VDI and trigger unattended bot(UiPath Robot), but after I update to UiPath Assistant, everytime I sign out VDI, the bot will disconnect and unable to trigger any bots. Do you have any ideas? Thanks!

1 Like

Could you please explain from where you are trying to trigger the bot.

Also any error you are getting if you can post it please…

Thanks
#nK

I trigger it from entreprise PRD Orchestrator, the issue is just the robot get disconnected after I sign out VDI, no error information because I can not even run it. But before updating to UiPath Assistant everything was good.

1 Like

Okay, so when you trigger it is it going in pending state ?

Yes, the process is pending in this case. Unattended Assistant robot disconnected, process won’t be running until I manually open VDI.

1 Like

Okay, So the issue you are facing is…

You have only enabled attended mode for your bot - that’s why you were able to run after login.

You also need to enable unattended mode for your bot by saving the VDI creds in orchestrator which will enable your bot to trigger automatically.

If you need more help on the steps, please let me know.

Thanks
#nK

Thank you, but I’m afraid that is not correct, because in my company’s OC, we only got unattended license, so all the bot must be unattended bot. Also, I tried to delete the bot in OC, and created the unattended Assistant bot again, the issue still exists - sign out VDI, UiPath Assistant robot disconnect. So I think it might be a bug of new version of UiPath Assistant, it’s okay with UiPath Robot.

1 Like

Could you please share the screenshot of the orchestrator machines and robot ?

Sorry I can’t. I can assure you that it’s an unattended bot, VDI creds are good, machines are good, environments are good, other VDI robots are also good, because they have not been upgraded to UiPath Assistant. All of VDIs which upgraded UiPath Robots → UiPath Assistant are not unattended any more since they always disconnect after sign out.

1 Like

Could you please confirm me the version of orchestrator and assistant please ?

Orchestrator 2020.10.5, UiPath Assistant 20.10.6, Thank you!

1 Like

Are you using classic or modern folders ?

I think it’s classic

1 Like

I believe all your machine name and robot name details match with the machine details !

Yes, they are matched, and if I manually login to that VDI, the process will start.