"Cannot start a parallel process from an unattended job"

Hello,

I have a group of unattended processes that I want to run simultaneously. For the past month, this process has been in Production, we have been using a “Master” process that reads a text file of process name and then invokes them all in parallel on the one bot. Obviously, this approach is very favorable in that it cuts down on overall execution time without consuming extra resources.

Although this process has been running error-free for th past several months, suddenly on 7/18, this stopped working. The process has started to produce the a “RemoteException” with the error message “Cannot start a parallel process from an unattended job.”

Since google search results for anything UiPath related yields hundreds of useless and irrelevant forum posts, I was unable to find anything specific to this error. Now, when we chose to implement our solution this way, we did notice that there were several conflicting / confusing posts about the usage of parallel execution on unattended bots - so we simply tested to see if it would work, and it did.

So, there are a few possibl options -

  1. The error message is misleading and something else is going on.
  2. UiPath revoked support for invoking parallel processes on a unattended bot, on purpose, without any kind of formal notice (as far as I can tell), ON A FRIDAY
  3. Someone at UiPath implemented this functionality incorrectly (since the wording of some of the aforementioned forum posts indicates that it should never have worked on unattended bots), realized their mistake, and pushed a bug fix to production ON A FRIDAY without saying anything.

Any support for this would be extremely helpful. I am quite frustrated with this since I came back from my weekend ready to deploy our next process, but instead finding that I have to fix this stupid issue and that all the data we were supposed to be collecting over the weekend was lost…

Either way, this is extremely unprofessional and makes me reconsider the stability of UiPath as a platform if these kind of changes can happen, especially on Cloud Orchestrator, which I understand to be the flagship platform for UiPath.

In UiPath a background process can start other processes within same machine.
It can start only 1 foreground process, but multiple parallel processes.


Hey Kanad - My Master Process is a foreground process but the subprocesses it invokes via “Invoke Parallel Process” are all background processes. I can change the master process to be background as well if necessary

Most probably that should solve the issue

@KanadMehta I changed the parent process to unattended as well, and it did not fix the issue

@KanadMehta I also upgraded all of the package versions, still getting the same error

Not only unattended, parent needs to be background process. Check Project.json file you will see foreground/ background property there

Sorry, i meant background.

Capture

@KanadMehta all the involved processes are background processes

Did you try this on unattended environment. On dev debug environment it will not work I guess.