Cannot sign into Orchestrator or Studio anymore

As of July 8, I can no longer sign into Studio or Assistant. I can sign into Orchestrator, but without Studio, there’s not much I can do.

Even when I could sign into Studio, I had issues with running processes in Orchestrator. I was only able to run them with UiAssistant.

For a while, I was able to open UiPath Studio to design and run workflows, but when I tried to reinstall it to get Orchestrator connected, Studio stopped letting me sign in, too.

Here’s everything I’ve tried:

  1. Restarting my computer.
  2. Uninstalling and reinstalling Studio.
  3. Logging in through Studio (clicking the sign in button does not give me fields to type my information into.)
  4. Logging in through UiAssistant (same, no fields to type into)
  5. I’ve also tried under “More Options” where it says to log in using an Orchestrator URL and a machine key.

I’m attaching some screenshots of different error screens I’ve encountered over the past few weeks in trying to solve this issue. Here are some brief descriptions of what they show:

  1. There are currently no configured robots in my Orchestrator, even though I set it to automatically create an Attended one. That may be related to the next screenshot…
  2. I currently have no license associated with my profile despite manually assigning one.
  3. As I said before, there is no robot configured, for some reason, and this message occasionally pops up when I try to sign into Studio.
  4. For some reason, there wasn’t a “Workspace” folder under the “Shared” one, but that has returned. Not sure how I fixed that…
  5. Error in Assistant: “Access to resource is denied: Error redeeming code: The SSL connection could not be established, see inner exception. / no description”
    (This is similar to the Studio error I’m getting in #7 below.)
  6. Error in Assistant: IInteractiveConnectFlow.SignIn thew System.IO.IOException: “Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host…”.
    (Similar to the Studio error I’m getting in #9 below.)
    I’m not sure what this means…
  7. Studio Sign In Error: “Access to resource is denied: Error redeeming code: The SSL connection could not be established, see inner exception. / no description”
    (Similar to #5 above.)
  8. Studio Sign In Error: Error loading discovery document: Error connecting to https://cloud.uipath.com/identity_/.well-known/openid-configuration. The SSL connection could not be established. see inner exception."
  9. Studio Sign In Error: “Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.”
    (Similar to #5 above.)

I’m pretty new to this, so some of the troubleshooting documents are a challenge for me to understand, so if anyone can walk me through exactly what’s going on here, I would greatly appreciate it.

Thanks for your help.

Okay, of course I just typed all that, and now I can sign into Studio again. I’m not sure what changed in the last 5 minutes, though I did edit some of the settings in my work account to match what they are in my personal account.

Now I’m getting this message, though:

I’ve gotten this one before, but I’m not sure how to fix it.

Furthermore, I am now getting these two messages that I am “unlicensed” despite clearly being assigned a license in Orchestrator.


1 Like

Are you still facing the issue?

Yes and no. I am not facing this exact issue I began this post with, but I am facing the new issue I wrote about above. Specifically, I cannot connect my Orchestrator with my Studio. I am getting the message: “Communication Error with Robot Service. Please check Robot Service status. Reason: Your login has expired. Please sign-out and sign-in again.”

@Nithinkrishna I just signed out of Studio to see if I could sign back in, and now I can’t sign in again. I’m getting the same messages as I was in my original post:

Now I’m back to where I started…

1 Like

Could you please make sure things are fine with network firewall …

Yes, I can try that @Nithinkrishna , but what do you mean? What should I be looking for? Here is what my settings currently look like.

Now, I’m back into Studio. I have no idea what’s keeping me from signing in sometimes but allowing me to sign in other times…

1 Like

@Pablito , @loginerror - is there anything that you may be able to suggest to help my colleague here? We have had another colleague with very similar issues but so far no resolution :frowning:

Thanks in advance!

Hi,
It might be also something related to VPN or proxy. Is it a company computer or network?

Yes, I am on a company computer, and I am almost always connected to our VPN.

This might be the reason. You need to check with your company’s IT dept. if there are not blocking any connection to the Orchestrator.

1 Like

@Pablito @katharine.hardy
Still working to resolve this. A colleague of mine worked for an hour this past Friday with me to try to make the connection, but we were not successful. Is there a way to reset my Orchestrator as if I were signing in for the first time?

(No update yet on if the connection to Orchestrator is being blocked.)

In the meantime, my personal account and connection to Orchestrator is working on my personal laptop.

It looks like this issue is resolved.

  1. When I tried signing into Orchestrator today, I did not have a robot configured.
  2. I went to Tenant → Users → clicked on the 3 dots next to my name → Edit → Optional Robot Settings → Clicked to automatically configure an Attended Robot (which also resulted in creating a workspace)
  3. Then, when I went to open a .xaml file, Studio had me sign in and choose the version of Studio.
  4. Once the file had loaded, it showed that I was connected.

I know I had tried this a few times before on my own and with others, but I think the work from Friday helped resolve the issue. I believe we deleted my workspace and some roles and such, but I cannot recall everything we did during the hour.

Happy to have this working again. Thanks for your help.

3 Likes

Unfortunately, @Pablito and @loginerror , this isn’t working again. I haven’t touched any settings since Tuesday. Getting this familiar error message:

Completely signed out of everything, went to Studio to sign in, and it opened Orchestrator in my web browser for me to sign into. I clicked that I wanted to sign in with my Microsoft account, then gave me the message below, and it’s not redirecting me. When I went to Orchestrator manually, I have some robot errors that I’ve never seen before.



Also, I don’t recall seeing this “Could not connect to the server (#101)” message before:

I contacted my IT department about this, but seeing as how it was working two days ago, I’m not sure why it would be a firewall issue.

Could you maybe check the Windows Event Viewer for the inner exception of this error?

Also, the SSL issues are typically resolved by making sure your system clock and timezone are correctly set (as simple as it sounds).

Having said that, it looks like there were some issues yesterday with the services, so that might have been the cause as well:
https://status.uipath.com/

Ok, thanks for the ideas. I can log into both my personal and work accounts and connect to Orchestrator from my personal laptop, so this looks to be an issue with my company computer and not UiPath.

I’ll update the post with the solution once we figure it out.

Sure. One other thing I recalled is the TLS 1.2 requirement, see here:

@loginerror im also having the same issue, my bot tends to connect briefly and then it disconnects. The assitant status turns red and says its connected but unlicensed. Ive tried changing the TLS setting to 1.2 and error still persists.

@olmccb Sorry you are having the same issue!

My IT department has tried just about everything to solve this. One thing we thought it might be, but it isn’t, is an issue with the bios time not being correct, leading to an authentication problem.

We’ve tried reinstalling UiPath, logging in a variety of ways, and reinstalling Windows (which failed for some reason).

I also checked the suggestion made by @loginerror , and I have use TLS 1.0, use TLS 1.1, and use TLS 1.2 all checked.

This is definitely some sort of issue with my specific device because I can log into my work account on my personal device with no issues.