Cannot select address bar on TypeInto element

selector
chrome
studio
p_known

#1

Hey, when i aim on the address bar in chrome when choosin an element on TypeInto the whole screen is highlighted, it works for all the elements in html, i doesnt work though for the chrome search bar… what is interisting, this only happens for me, my collegues with same project, same browser can do it with no problems what so ever


#2

Hi Jonson!

Do you and your colleagues have the same version of Studio? And could you tell us which version?


#3

image
Sure sorry about that. I believe its the same version, if not i will let you know.


#4

Hey @Jonson

Well it might because of Either chrome uipath extension installation issue or .net version issue :slight_smile:

but you can use below selector with Type Into Activity. :slight_smile:

<html app='chrome.exe'/>
<ctrl name='Google Chrome' role='client' />
<ctrl name='main' role='tool bar' />
<ctrl name='Address and search bar' role='editable text' />    

But Instead of Type into better to use Open Browser Activity with Navigate Url Activity :slight_smile:

Regards…!!
Aksh


#5

@Jonson Please check your DotNet Frame work.
also verify what your colleagues are holding DotNet Frame work version in their machines and try to match with them.
That will fix this issue…
hope my inputs are useful. :slight_smile:


#6

@Gabriel_Tatu If you can take a look into this please. Version 2017.1.6498


#7

yes, it is a known issue


#8

My friend who got no problems with that has vesion 2017.1.6435.

My .Net vesrion is: .NET Framework 4.6.1, my friend has the same.

So, if its common, i guess i should use @aksh1yadav way of doing it?


#9

@aksh1yadav way was suggested to operate with selector but with out proper DotNet framework, Google Chrome extension won’t detect elements on google chrome… so first un install all your Dotnet Frame work and re install. as a next step, please remote your Google chrome extension and re load it. hope that will fix the issue. Make sure you have local admin rights on your PC/Laptop.

of course, am not a new doctor but old patient :smile: faced same problem with one of my VM.


#10

But as mentioned above, my friend with the exact same version of dotnet is not facing the issues… so i think it is a more of a studio version problem… And as Gabriel mentioned, it is a known issue, so i hope its gonna be solved some day soon?


#11

FYI :slight_smile:

Regards…!!
Aksh