Cannot run Excel activities in Studio without Excel becoming unresponsive, execution never completes

Hi all,

I am trying to complete one of the UiPath Courses, this one being “Build Your First Process With Studio”.

Whenever I try to run this, Studio runs the process but is unable to complete it. Once Excel opens, it freezes, then becoming unresponsive. The process never finishes.

Here is what I see when I try to debug the file:

I have tried reinstalling Studio three times, I have started an entirely new process 5 times, yet this problem persists. The Excel package is installed, and I have tried adjusting the version to the one recommended in the tutorial but still no luck.

Any ideas?

Thank you.

Kill all Excel processes from task manager and then try

You could also use kill process activity

If it still doesnt work use Excel Application scope from classic design activities and then try.

When you open the file manually, it opens fine without a hassle right ?
You tried classic activities too ?
Also change file location and then see? Try for a .xls file

Just to get an idea why its failing.


Please try using excel process scope and in that you have settings which yu can set options in its properties…please select excel as not visible and then open as automation and check…

Alternately try using save as on file and svae as different file and check if it works